IFC Export - Error with handling of transaction request

Hi all,

Getting a bit of a weird error while trying to use the Genius Loci IFC export node which I can only attribute to some error in its placement/use within the transaction of the primary script run.

The below screenshot outlines the segment of code in which I am ensuring all previous actions in the script are complete before passing on data for the export node (as shown it fails).

What is weird is that if I unplug the ‘directory’ input from the IFC export node, run the script so that it fails, plug the directory back in and run the script again it immediately begins to export an IFC…

Therefore I know the data I’m feeding the node is correct and assume it must be something to do with the transaction handling. I tried to rectify this with the brute force Transaction.End then Transaction.Start but still to no avail.

Anyone got any ideas?


Hi @haganjake2,

This node was intended for use with a document input (Revit file open in the background or unloaded link).
In the current document use the Export IFC node which normally handles transactions.

1 Like

Alban to the rescue!! Knew I could rely on you for a helpful response in relation to this node haha.

Thanks so much for pointing that out, it works a charm with the regular export node.

Got a follow-up question in relation to a similar node of which I assume isn’t working for the same reason…

Trying to get an NWC file to export before the IFC but this time there is no Export NWC node only the ‘Export NWC in Document’. I tried to cheat it by giving it the active document but with no luck. Any sugestions? Also any idea why the output dictionary values when the node fails are a T & R? Would be good to have those as null rather than what it is currently.

(I also have a suggestion, would it be possible to include a ‘Runit’ on the Export IFC node similar to the NWC in doc? This would mean ultimately if the user decides not to tick the button to export an IFC I can make the script run without errors by passing a false into it)

@Alban_de_Chasteigner Bumping incase you missed my second question :slight_smile:


The transactions are not required to export to navisworks. So I don’t have a satisfactory answer apart from resetting the input Runit.
Please note the difference between the Dynamo document and the API document (without wrapper).
Unfortunately it’s not possible to use Dynamo documents with custom nodes.

I note it.

Hi @Alban_de_Chasteigner ,

Apologies for the late response I haven’t had a chance to look at this since last week.

Appreciate the flagging of the different wrapped and unwrapped current doc nodes!

As for the NWC node I’m still having the same issues with it even in a test environment. I’ve checked the setup/inputs against the example you have given here: Export NWCs from Revit 2020 to Directory Path - Consistency Issue - #4 by Alban_de_Chasteigner

But it still gives the same outputs:

Have tried re-plugging the runit etc - Any suggestions?

Am running Genius Loci version 2021.4.13 in Dynamo 2.6.1.


Does it works with the Revit interface (without Dynamo) ?
It is working fine for me with Dynamo 2.6 and a reset of RunIt.