Genius Loci // Export to NWC Issue

Hi there – I’m having trouble with the ‘Export NWC in Document’ node from Genius Loci. I’m simply not getting the correct output – I previously had this script setup in a different way, but the ‘Export NWC in Document’ node has always been there and worked before (last time used about a month ago). I’m now getting a result here that does not make sense to me – has anyone seen this before? ‘Result: T; Document: r’

No errors or issues, just not completing properly. What am I missing? TIA!


Hello @ashley.hastingsWB did you try what i suggest in last post…i mean something…

If it still not work for you, you probably not have Navisworks NWC File Export Utility installed…can be found here…



Hi Søren – I had tried the update you mentioned in the previous response, but it didn’t work at the time. I’ve just gone ahead and mimicked exactly what you had in this last response and it seems to be working :blush: I did think it was the NWC exporter, but I had that installed (new machine for me!) last week, so that wasn’t it. Must’ve just been something in how the graph was setup originally. Something that is coming up for some reason is a print setting dialog box as it’s trying to run each view – do you know what would cause this? This is new.

Thank you for your help!


Nice it could work,long time since i had bluebeam installed but if i remember right its a bluebeam setting :wink:

1 Like

I wound up just changing the print setting to Bluebeam and that seemed to stop the box from popping up. Just not sure why it came up in the first place :smiley: Looks like we’re good to go – thank you again for your help, @sovitek!

1 Like

Hi again – well, after some updates over the past several months, it looks like that something’s amiss again. In Revit 2023, I’m receiving a ‘success’ from the completion of the script; however, nothing is exporting. Currently have Genius Loci 2023.7.13 and 2024.217.1024 installed, as well as Revit Exporter installed. Any thoughts on what might be causing the views to not export?

My suggestion will be - have you installed DynamoIronPython2.7 package yet?

And you may try to switch 1 to true for RunIt input in the last node.

Also, it would be better if you upload graph image with outputs pinned for all nodes

Hi @Andriy – thank you for your help. Yes, I did have DynamoIronPython 2.7 installed – previously the 2.4.0 build and just updated to 2.5.0, but no change. I also tried switching from 1 to true for RunIt, and no change. Here’s an updated graph:

Everything seem to be lookin good. The only few things I have in mind

  1. Try to use longest lacing
  2. Go inside the custom node Export NWC and look if there are any errors there. Or also you may copy script from node to main graph and see if it’s running correctly

Question. Can you do this manually with revit. Ie what i am asking is do you have the .nwc exporter installed?

1 Like

Yes, it works manually with Revit — also mentioned this in my first post today, among other things :slight_smile: The issue is that because it’s a multidisciplinary internal coordination model I’m setting up, there a several views, and I’d love to just run it in the background. I’ve had previous success with this earlier in the year, but Revit 2020. So, the script has worked before.

yeah havent try in 2023-24 as i use either diroots or birdtool for that kind…but i will try later :wink:

have just check in 24 and it works as least for me :wink: which genius loci package do you have installed ? arh i see now in your post its the newest that should be fine

Any thoughts on what the issue could be? I’ve tried different file paths – no change. Still getting the same ‘success’ result too. I love when things only happens to me :smiley:

Looking into it further – I do get the following feedback:


And if I click ‘Install Specified Version’, I get this error (despite having 2023.7.13 installed):


Can both be installed simultaneously?

1 Like

Close all Revit and Dynamo instances. Navigate to your package directory(s). Find the Genius Loci folder(s) and delete it. Relaunch Revit and Dynamo. Install the latest version of Genius Loci from the package manager. Open the graph and select ‘use installed version’. See if that works. :slight_smile:

1 Like

Thank you, @jacob.small – bit of package cleanup did the trick (shocking!). I also had the old custom node at the end of the script that had been updated in more recent versions of Genius Loci. Running smoothly – crisis averted :slight_smile: