Help with Tag.ByElementAndOffset

I appreciate all the assistance I’ve received previously on this forum. Thank you! I Been stuck for a couple of day now. Again, I truly appreciate all the assistance I’ve received here.

I’m getting two errors when using the Tag.ByElementAndOffset or the Tag.ByElement nodes. Any help? I’ve exhausted all my ideas. Is there a better way to tag something?

Put input in VerticalAlignment & Horizontal in Tag.ByElementAndOffset

Thanks for the reply. I just tried that but it didn’t work either. Any other ideas?


You need to be using booleans for true or false. You’re currently using a string for addLeader.
Also make sure your view isn’t an area plan and that you have a compatible tag loaded.

Thanks Nick. I tried that as well. Still no luck. Any other ideas?


Can you share your rvt file and the graph?

Absolutely and thank you! Here’s the graph. Sending the RVT soon. Its too big at the moment.

Exiting Capacity.dyn (35.7 KB)

Hey Nick,
I can’t purge the RVT enough so its small enough for uploading. It’s only 4 walls and 2 doors, No legends, sheets schedules… Only 1 view. Will the forum allow zipped files for uploading?

Hey Nick,
It won’t let me upload a zip file either. Are there other options to get the RVT to you?

Any file sharing platform like Google Drive or Dropbox will work. Private message me with a temporary link or a request for my email if you need it.


It does return an error but it seems to be placing the correct tag in the correct location. What does it seem to be missing?
Edit: Seems like it’s not quite at the offset specified.

If I select a different type of the same tag it ignores it and places the initial type.

If I select a different type of the same tag (in Dynamo) it ignores it and places the initial type.

Sorry. I purged out the other types of that family when I was trying to reduce the file size. I can send you a new version or you can duplicate the type, select the new type in dynamo and see what I mean. It’ll ignore the new type and place the initial type. Thanks for your time Nick.

Are you saying if you try to change the tag type to something else (in the Dynamo selection) it doesn’t change the type when it gets placed?

They Tag node is running and hitting a manageable exception so it’s placing the tag but still failing. There’s no tag output so there’s no element to change types on.

What I’m trying to do is to set it to a family and a desired type before it’s placed. Changing it after it’s placed (but before the graph is finished) would be ok too.

For instance, if the door tag type has two or more types I’d like to select the desired type in dynamo (or the player) before running it. Thanks

That node just uses the default tag for the category as setup in your project. There are other nodes that allow you to select the tag type.

Ok. Good information. Do you know which one(s)?

I usually use Create Annotation Tag from Archi-lab. It doesn’t allow you to offset though.

Hmmm. I tried that node too. Couldn’t get it to place the tag or throw an error. Just didn’t do anything. I must be missing something there. Offset is not important, I’m willing to sacrifice it if I can get the rest to work. Thank you.