Graphics issue


#1

Hi guys,

I am having graphics issues. When I place a node to obtain some 3D object like a cylinder, cone, etc, the 3D background turns into half of the available workspace. As you can see, in capture 1 everything is good but when I connect Cylinder.ByRadius node, the workspace reduces to half (see capture 2). And the same happens when I connect the node Cone.ByPoint. I think the problem is when I try to reproduce a 3D surface.

capt1

capt2

cap3

I am really sure that is a graphics problem, but is there a way to fix it?
Specifications of my computer are in the following capture. By the way, It has integrated graphics (Intel® HD 3000)

004

I know that a graphics card is needed, but I think there must be a solution to this issue. Hope you help me. Thanks in advance

Regards,

Cesar


#2

So, are you saying that currently you have NO graphics card in your computer?


#3

I did not explain that so well.
My laptop does not have a dedicated graphics card


#4

My guess is that this is likely the issue.

Not sure if you’re in studio, core, dynamo for Revit, or some other home-brew. I can’t readily find the requirements for core, but the published requirements for Dynamo Studio are “3d Graphics in Dynamo Studio requires Windows 7 or Windows 8 with a DirectX 10 compatible GPU” and I believe Dynamo for Revit has the same requirements as regular Revit (which you don’t currently meet).

A possible work around which I haven’t tried (you’re already into unsupported territory here) would be to disable the back round preview and rely on watch 3d nodes. No idea if it would work.


#5

with background preview

without background preview.

As you see, the issue appears on watch3d node too.
I usually work fine with Revit. By the way these captures are in Dynamo for Revit but the same happens in Dynamo Studio :frowning:


#6

4

It’s DirectX 11 compatible sr.