Get Rooms by Level not working?


#1

Is anyone else having trouble with the Get Rooms by Level node? It was working for me previously and now I am getting nothing but null results. I have tried both versions 0.7.5 and 0.8.0, still no luck…

1_GetRoomsbyLevel_0.8.0

 

 

2_GetRoomsbyLevel_0.7.5


#2

Just created a simple dyn here

이미지 1

 

 

Download link


#3

Where does the IndicesOf node come from?


#4

Was this resolved - I’m having the same issue in version .8


#5

This is in 0.8.1 and it appears to be working as it should.

2015-06-08_09h42_22


#6

Just downloaded 0.8.2 and i still get no rooms showing up - more thoughts?


#7

You could select all rooms. Use element.levelnameasstring from rhythm and use a filter by bool mask as well.


#8

Hi All, I have the same issue, but only when working with Revit2016. The same Dynamo graph (8.1) works with Revit 2014.

I think it’s something with the level parameter of the room, may be a API change that breaks the node functionality.

 


#9

Did you try the filter I mentioned?


#10

Hello Miguel Salvador,

Is it possible for you to share your files? (dyn and rvt) otherwise I will create new sets to test it on my side.

Have you tried in Revit 2015?

Revit 2016 is RAC or its a a simple Revit?

Thanks for the info.

-Ritesh