Geometry Rotate problems

Hello everyone,

So, as seen in the print screen, I picked two points from a surface in Revit, and now wanted to create multiple lines around both points. However, when using the “Geometry Rotate” node, the result is not the one I desired. As seen in the print screens, if using the shortest lacing I only get 1 line. By using the longest lacing I get one good rotation around one point, but the other is wrong. And by using the cross product lacing I get more lines than the ones I wanted in the first place. Any suggestion to resolve this?

Prints:


image
image

Thx in advance!
Luís Sanhudo

Ou need to tweak the list levels to work with longest lacing on level 2.

Hi Jacob, thx for the reply. Would can I do that? I know how to flatten a list, but can’t find how to add levels to one.

On the node input, see the little arrow on the right side. Click this to access 'level options for the data input.

Lacing options are found by right-clicking on the node itself.

3 Likes

Just to be sure this is clear:
image

You should probably review the section on lists in the Dynamo Primer to avoid some future headaches as well.

http://dynamoprimer.com/en/06_Designing-with-Lists/6_designing-with-lists.html

3 Likes

Thx Jacob and Ewan. Thx for both your help!

2 Likes