Framing Element overshooting Reference Point


#1

I’m curious to understand why my framing element overshoots the tops of the columns so substancially throughout the entire row. Carefully checking the list of points lines etc. everything appears to line up up nicely but when sending to REVIT the elements are too long. It appears fixable with post-processing in REVIT but I much rather control this behaviour in Dynamo and perhaps learn just a little bit more about this awesome program. Thanks.

15-10-16-a beam extension issue

 

 

 

 

 

 

 

 


#2

 

 

 

 

 

 

15-10-16-b beam extension issue

 

 

 

 

 

(Sorry. Edits to OP are not reflected in the forum.)


#3

This is due to Revits auto setback for beams. Check out this blogpost for how to turn it off. http://bimandbeam.typepad.com/bim_beam/2009/07/framing-templatehow-to-disable-auto-setback.html

Don’t know any other way, but maybe others will have better answers for you.


#4

This might solve the issue…

20151018-3


#5

Unforunately VS, your suggestion fails at the Set Paramenter node with what I think is an unrelated internal error: “Warning: Internal error, please report: Dereferencing a non-pointer. (3f47aacd)”. I’m suspicious that setbacks are the cause anyway because the +3000mm overshoot is not recorded in the properties.


#6

Blair, could you upload a demo Revit file containing the offending elements?


#7

15-10-20 beam extension issue

 

 

 

 

 

HEXLIX test eviro1

I’ve tried my best to link the file. As I’ve continued to investigate I’ve noticed each strcutural member is variously missing the “Start Join Cutback” and “End Join Cutback” parameters in REVIT. This, therefore, returns an error in Dynamo. Setting a simple instance parameter like “z-offset” in Dynamo works without issue. of note is that the parameters missing in Revit are the structural memebers which overshoot the reference point.

 

 

 


#8

15-10-20 beam extension issue

 

 

 

 

 

 

 

(Re-posting for clarity.)


#9

You could use the Start Extension and End Extension instead.

But the problem is that in spite of these two being 0 in your demo Revit file, the ends of the beam extend beyond/fall short of their start/end points.

Don’t think altering parameters with Dynamo will help unless we identify a pattern/reason that explains this behavior.


#10

The issue here is the Beam/Column Joins. You can edit the behavior by clicking the Beam/Column Joins button and adjusting the arrows. If you are handy with the Python, you can write a small script using the StructuralFramingUtils.DisallowJoinAtEnd method to automatically prevent any joins at those beam ends (note that this would result in an overlap with the column geometry, but that might be better than the overshoot). You can manually do this by selecting a member, right-clicking on one of the end nodes, then select “Disallow join”.

BeamJoins


#11

Hmm. Despite not getting the exact effect I’m looking for it can not be said I didn’t learn anything in this thread. It is, indeed, somehow connected joining. And though while learning python is a long term goal I guess for the foreseeable future I will have to settle for doing some post-processing before exporting the geometery to Illustrator - which I’m fine with - except that eventually I will be embarking on much bigger paramentically driven structural models for which my goal is to limit post-processing workflows which necessitate udpating every structural element by hand.

Thanks for your help for bring some concrete answers to this problem.


#12

Hi,

This is more of a Revit problem, than a Dynamo one. I have a solution in spring nodes, similar to the one Ben mentioned. It evaluates he beam’s cut length and length parameters and filters out the beams that have large extents. Because your beams are quite short, you’ll need to use a small margin:

2015-10-27_16-17-26

 

 

 

 

 

2015-10-27_16-12-46