Fonts in Dynamo displaying a box instead of a Hyphen/Dash

I’m not entirely sure what caused it, but hyphens/dashes are replaced with an empty box as shown below:











I have already tried uninstalling and reinstalling and reinstalling the arial fonts, but it persists. Does anyone have any ideas how to resolve this?

Its working fine from my side. Which dynamo & Revit version your using?


I’m using Revit 2016 and also Revit 2015, I had been running dynamo version 1.0, and after your question tried upgrading to a daily build in hopes that it may resolve the issue. It has not.

I also verified that it was one the - character, all other symbols and letters seemingly work fine.

I have same problem. Started back with version 9. Still happening version 1.

This looks like font not having the glpyh for a particular character. Boxes show up when there is a mismatch between Unicode characters in the document and those supported by the font. Specifically, the boxes represent characters not supported by the selected font. Look at the settings of your font in windows “RegEditor” and also i would suggest you guys try to restore your windows fonts to default. See if it helps!

Sadly, none of this has worked, I have even uninstalled dynamo, deleted all related registry keys, removed the folder from appdata, reinstalled Revit, and reinstalled Dynamo. At this point I dont believe it to have anything to do with the font as the fonts appear to be arial, and I have test all arial in other programs including Revit itself. The issue only seems to be for one character in Dynamo. Obviously not something will hinder performance, but it is extremely bothersome since I try to develop workflows for my office with screen shots and videos. If anyone has any other ideas I’m game.

What is your system configuration?

Out of curiosity what are you expecting the hardware to point you towards in this issue? It used to run fine, and there are dozen of other people in my office with the same machines. I’m not trying to be rude, I appreciate the help, but I’m worried we might head down a rabbit hole of blaming throwing blame at the machine.