Dynamo library is not displayed


#1

When the Dynamo library disappears, there is a workaround such as erasing other add-ins and updating Revit, but no matter what you do it will not be displayed.
As for add-in, Dynamo 2.0.1 was able to be used when using what the company decided.
I erased pyRevit with the add-in I put in later, but the library is not displayed.
I tried uninstalling Revit 2018.2, making it 2018.3, updating Dynamo, and doing other things that are posted on GitHub, but it is not displayed.
Please tell me how to deal with it.


#2

What Revir version, and what Dynamo version are you currently using? Have you disabled all add-ins or was it just PyRevit which you disabled?


#3

At first I was using Dynamo 2.0.1 with Revit 2018.2.
At that time, the Dynamo library was displayed.
When installing pyRevit and uninstalling pyRevit, Dynamo library is no longer displayed.
Other add-ins are intact.


#4

Try uninstalling and reinstalling Dynamo, you may have lost some key components when you uninstalled the other addin.


#5

Thank you for your reply.
I changed the version of Dynamo to 2.0.0, 2.0.1, 2.0.2 and repeatedly uninstalled, restarted and installed several times.
I uninstalled anything that can be erased with add-in, and reinstalled Revit.
I tried these two tasks over and over yesterday, but the library is not displayed.
It is displayed only when installing with version 1.3.
I also uninstalled this 1.3.


#6

Can you post a screenshot of what your library currently looks like?


#7

look in your dynamo console for errors, and look if there are any green notifications in the dynamo menu. Something is stopping CEF from loading.


#8

Thank you for your reply.
The blue square is not displayed.
Sorry if the error is difficult to understand because it is Japanese.
This screen is in the state when you added the package, but even if you uninstall the yellow square package, the blue square part is not displayed.
It is the same even if Revit and Dynamo are reinstalled after uninstalling the package.


#9

I would look for logs or notifications related to CEF or CEFSharp - I think you can safely ignore the archilab warnings.


#10

Thank you for your reply.

Looks like it.
Even after Revit and Dynamo are reinstalled after uninstalling the package, the blue square is not displayed.
When I downloaded the archlab package, it says that it is compatible with Dynamo 2.0.1, so I was using Dynamo 2.0.1, but I got an error.
I erased the package, Dynamo’s core, Dynamo’s exe and reinstalled Dynamo, but Library Bar is not displayed.
I erased other add-ins such as pyRevit, I also erased Dynamo, reinstalled Revit after uninstalling, reinstalled Dyanamo, but the Library Bar is not displayed.
Since it is a version compatibility problem, it is only necessary to drop the version, but I hesitated at the thought that it was troubled that what I made in 2.0.1 could not be used.

Thanks to everyone who gave me advice.


#11

Sorry for asking so many questions.

After that, I tried what I was able to do, but the library bar was not displayed.
Please tell me how to deal with CEF # errors.

Thank you very much.


#12

Can you confirm your current Revit build?

Update Revit to the current version if you don’t see one of the following:
18.3.2.7
20181011_1500(x64)
2018.3.2

See if that solves the menu issue.

If not, try uninstalling ALL Revit add-ins, as directed here.

Then see if the library shows up. If it does then start adding back addins (“when testing complete” line of the last link), restarting Revit and testing Dynamo as you go. If it doesn’t let us know.


#13

Thank you for your reply.

Revit version is 2018.3.2.

I tried several times to delete Addin of Program Data, but the library bar did not appear.
I am creating a Dynamo file that I plan to share with other people, so I can not uninstall all add-ins.
I uninstalled add-in which I normally do not use, but the library bar is not displayed.

For the add-in that was originally there is a library bar and it’s add-in that everyone is using by the company as standard, so even if it is uninstalled and displayed it makes no sense.

Currently, I can use the data of Dynamo 2.0.1 I have used so far, but I can not modify it because I can not add nodes.

The problem is that the library bar was displayed at first but it suddenly disappeared.
And even if you uninstall the newly added add-in, it will not be improved.
I am in trouble because I can no longer modify what I was using.

Thanking you in advance.


#14

The problem is that one of these add-ins almost certainly using a conflicting version of the code which Dynamo uses to display the library, and other content. This and a lack of updates (which you confirmed isn’t the issue) are the main two reasons we have seen for this behavior.

So, try removing the add-in for the time being and see if that solves the issue. If it does, then we know where to start.

If after you have removed add-ins you still don’t have a library, please record a screen capture showing each of the following, in order:

  1. An empty add-ins directory
  2. Launching Revit from scratch
  3. Start a new project
  4. Open a Dynamo for Revit instance

#15

Thank you for your reply.

One way to solve this error was to change the version of Revit to 2018.3, so I changed it to 2018.3 which was 2018.2.
In that case I uninstalled all of the add-ins, but when installing 2018.3 we added company standard add-in as per the company’s procedure.
In any case, there is no point unless it moves in that state, so this time I decided to rebuild my old one using Dynamo 1.3.
Because I can not change the company standard.

Thank you for telling me so much, I sincerely thank you.


#16

Hi,
Am also fall into such problem but i solved it by upgrading Revit and uninstalling previous version of dynamo and after uninstalling i manually removed the dynamo folder from program files and program data file, then reinstalling solved my problem. I did this according to a forum thread (i forgot which but so far i remember, where it is suggested to upgrade Revit and manually remove dynamo’s program files folder after uninstalling it) .

But i will tell you a very interesting method that suddenly popped up in my mind and that solved again the same problem today for dynomo in latest version of Formit! Here also same problem occurred when i ran dynamo in Formit. No library nodes are showing up. I then went to check my Revit (19.2.0.65
20181217_1515(x64)
2019.2) and saw that, its dynamo version is 2.0.2. and Formit(17.0.1)'s dynamo version is 2.1.0 while in Revit dynamo is showing library but not in Formit dynamo! Suddenly i felt, what about if i try to install any dynamo package from online (Packages> Search for a package) just to see if that package node will pop up in library or not…and omg…it is with all library nodes shown their faces along with that package node in Formit dynamo! It was a very happy moment cause just installing a package solved this problem. I don’t know, if it will work for you in Revit dynamo but you might try this and let us know.