Floors from curves

I want to create floors from boundary curves. I have already posted the problem with a room in a room (see the room in the preview). I have used the nodes Group Curves and then PolyCurve.byJoinedCurves and I get the list as you can see in the image. I want to create floors from this list but get the error “BSPlineCurve not implemented” at the Floors.ByCurves node. Does anyone know how to solve this? I think the problem is the room in the room (see the list shown in the image)


You need to feed not the polycurve but the list of curves into the Floor.byCurves node.
You can try with the built in Floor By Outline nodes


P.S. Other possible problem could be the list structure you have for the polycurves list.

Thank you for the help! :slight_smile: I have tried that node as well but I always get this error:

I thnik the problem is the structure of the list, but I am not really sure how to fix it…

And later on I would like to split the floors by the red curve. Is it possible to split floors or do I need to create the final result with curves before I create the floors?

From the error here I can say that your curves should be checked.
Make sure that your set of curves are correct and not having too short curves or inconsistencies in the grouped curves.

If you upload the revit file (if possible) further help can be provided = )

As for the “red line” I’m not sure where the red line is and how you want to split the floors but I will recommend - create the needed curves first in Dynamo and then create the floors - it will be easier. This is my opinion.

How do I know the tolerance??

It depends on your project units but the error will appear for very short curves. Just inspect your input. The floor node is working properly, so now you just need to check twice the input curves.

I think the problem is that one curve is included in two floors, which means that two floors will be crated at the same place. Do you know how I can delete duplicates in a list? In my case I think it is floor 5 and 9…

The problem was the unit. When I changed to meter in Revit everything worked perfectly :slight_smile:

1 Like

i need your script.please send dynamo script