Create floors from polycurves issue


#1

Hello everybodies,
I actually would like to create floors and walls from polycurves but I am still in troubles and I don’t find a solution.
Do you know how could I have to proceed to solve this can of issue’s node and extract component in Revit?
Thank you very much.

EMI creation floors and walls from polycurves.dyn (24.5 KB)


#2

@miathou what is the error you are getting on the Floor.ByOutlineTypeAndLevel node?


#3

Hi,

I’ll need some time to look into it, but my first thought is that there are 2 version of the FloorByOutlineTypeAndLevel node. There is one that has an outline input formatted for multiple curves. Could you try replacing the Floor.ByOutline node with the multiple curve version and reporting back the outcome?

Best regards,
-Nick


#4

Hello @awilliams,
Like we see,I can generate Floors, but I can’t create components in revit from this dynamo script, because, as you can see the “Floor.ByOutlineTypeAndLevel” node clearly doesn’t work!
This is the issu and I still don’t know how to fix it!:sweat_smile:


#5

Hi Nick,
I tried to replace this node by a the other node with multiple curve version but it still doesn’t work!:disappointed_relieved:
You can look into it!?:wink:

EMI creation floors and walls from polycurves.dyn (24.5 KB)


#6

the node telling me : Warning :Floor.ByOutlineTypeAndLevel operation failed.
The multiplicities of other interior knots must be at most degree - 2.
Parameter name: knots
by the way


#7

Miathou, please stops duplicate topics.



Please explain why the solution already provided doesn’t work.

Add your Rhino model to your original post if you want some accurate help.


#8

Rhino model to test rhynamo.3dm (156.4 KB)


#9

You must make an approximation of your rhino nurbscurve.

Creation floors and walls from polycurves V2.dyn (1.2 MB)


Floor.ByOutlineTypeAndLevel node issue
#10

Thank you very much Alban!
After draw a serie of polycurves on my spline, extrude this curve and rebuit this shape, I used your script solution… And Tadam… It workes!:blush:
Thank you very much for your Help!
Sorry again to post to much topics.


#11

You’re welcome.
You can change the amount 40 in the codeblock 0..1..#40; if you want more precision. (the segmented walls will be shorter)

Please mark the post 9 as solution to facilitate similar researchs in the future.