FamilyType.Duplicate creates family type in wrong family

Hello everyone,

I tried to automattically create new family types from an Excel spreadsheet with has a lot of duplicate family types on there.
But when i tried using the familytype.duplicate node it duplicated the family type into the wrong family, even though my list levels/ lacing are setup correct (i think). See my screenshot below:

On the first screenshot i even made sure the list all were the same, but the output was still wrong.

PS: This node is from the Clockwork package (2.x)

Thanks in advance.

After some more trial and error i thought about splitting it completely, but no i have absolutely no clue what is happening here:

I spoke too soon. I believe this issue is caused by rerunning the script a couple of times. I did press undo in Revit but Dynamo will still see the families that were created in the run before that.
When i remove the duplicated families and restart Dynamo, the families are placed in the correct type.(when i run it again the families get placed in the wrong type because the name allready exist.) Will leave my post up for anyone else encountering this… :slight_smile:

I am having the exact same problem so i am bumping this thread.

censored company name abreviation in below screenshot but the problem is still clear.

I am feeding the desired family type (cycled) and feeding a list of 8 names.
Unfortunately the duplicate node does not place the family in the correct type…

Is there any solution to this issue?
(also clockwork 2.x )

1 Like