Family Instances to Element List Query

I am obviously doing something wrong, however, l have a list of Family Instances, which l wish to alter a named parameter by a varying amount, however, it return null. Why?

It states that "Parameter names and values must have have matching list lengths.


Any thoughts at all Ewan. I don’t recall receiving such a message before.

Looks like your list structure doesn’t match. What does your list of values look like?

Hi Nick,

Here are the lists, prior to Flatten node.

The lists after Flatten appear to be the same.


I am trying a variety of permutations, yet no joy.

I am sure l have done this many time before to set element parameter values, yet these lists or list is causing an issue on this one.

Your element and value lists look like they probably match in structure but you’re only supplying a single parameter name. Try setting list levels to @L1 for the parameter name.

I have just tried that suggestion. It didn’t solve it.

I don’t understand those levels, however, l have tried changing the levels based upon your suggestion and nothing.

I am attempting a whole variety of permutations.

Bloody Dynamo…well…bloody me! lol

I am trying to relate an image to the wall facade brickwork, however, it seems there is a numerical difference which could relate to the error message.

If you don’t need to keep your elements grouped for later in the graph I would just flatten everything completely. If you are going to be using the elements later on I would try duplicating the parameter name for every value you have so that all inputs have the exact same list structure and length.

I have tried flattening everything pretty much, however, the list structure appears to remain the same.

Regarding duplicating the parameter for every value, l have thousands of instances. How do you multiply a parameter thousands of times?

Then you’re not using Flatten correctly. Try it without an Amount and without any lacing.

Cycle or OfRepeatedItem will duplicate the input a given number of times. Just use Count to get that number.

I’ll try your tips Nick. :slightly_smiling_face:

To let you know what l am attempting to do, it to create an individual brick facade, using a generic brick with mortar family, then locate the required number of bricks, then drive each brick with an offset via it’s offset parameter within the family, to shift each brick by an amount relating to the red value associated to the linked image.

I am getting the bricks in, it is the adjustment of the placed elements regarding their shift that is the issue.

Dynamo isn’t placing anything now. Ridiculous.

Flatten doesn’t appear to have flattened it??

Tried this…no joy, even though lists look the same.

Could you try running the graph in Dynamo 2.0.3 or above?
Just see if it is the same outcome?