Export Schedule Data to Excel

Hi everyone,
I am trying to export schedule data to excel using the Bimorph node Schedule.GetData. The issue I am having is that when I set removeHeading to true, the node will remove two rows, regardless if it is a heading row or not. Another example is if the schedule header consists of three rows (multi layer grouping), then setting removeHeading to true will only remove two heading rows and not three.

My question is, is there a way to fix this issue or is there a different node that will extract the schedule data without the header, something similar to the OOTB ScheduleExportOptions.ByProperties node?



To better assist you, can you post an image of your graph or if possible attach a test Revit file and the .dyn file?


See attached screenshots. The issue is not with the graph but it’s with the bimorph node, specifically when you set removeHeading to true.

The first screenshot shows a schedule with multi-layer headers and when you set removeHeading to true, the node removes two rows of headers and not all three rows.

The second screenshot shows a schedule with one row of headers and when you set removeHeading to true, the node removes two rows (the one row of headers and one row of data - 3-EF-1 row in this schedule).

Does anyone have any ideas on how to fix this node or are there any other nodes that will get schedule data without the header? Thanks

@paliitali These are the 2 workarounds that I can think of. See if it helps.

Hi @AmolShah, do you know if there is a way to count the number of header rows and count the number of data rows in a schedule? If there is a way then option two would work starting from the correct row. Thanks

I was able to figure out how to count the header rows and schedule data rows by using schedule.getdata, all elements in view(s), list.count and code block node. Thanks

1 Like

Great that you solved the problem, but isn’t this a solution to a non-existing problem?

Why export the schedule if you can just query the elements in the model for exactly the same information?

Hi @paliitali

This is a bug in BimorphNodes. For now keep the ‘show blank row’ option on in your schedule and you will always get the correct result as that’s what triggers the problem. Headers can be on or off.

Hi @Thomas_Mahon

If ‘show blank row’ is on and removeHeading is set to true, the BimorphNode will only work if the schedule has no group headers. If the schedule header has one group or multi-layer groupings then the output will be incorrect.

Hi @Bjorn_Keulemans1

It is much simpler to export a schedule than query specific elements and specific parameters, especially since element/parameter requirements can change