Excel reading problem, Dynamo 0.8.1

I used to have a Dynamo file which was reading an excel file successfully in Dynamo 0.7 and 0.8.0. But as soon as I updated to version 0.8.1, the excel file doesn’t open anymore and I get this error: “Warning: Excel.ReadFromFile operation failed.
Exception from HRESULT: 0x800A03EC”

Does anyone know why I get this error and how to fix it?

Hello Shani,

Sorry to hear that your old file not working on new version of Dynamo.

We did a lot of bug fixes for Excel in 0.8.1. We might have regressed few things.

I would like to see your DYN and Excel file to solve your problem.




There is a package called Bumblebee in Package Manager. It has a lot of great Excel functionality.

Here is also a book developed to explain in details what it can do. I believe that it will be quite useful for you:


Thank you,

<span class=“author-link”>Ritesh Chandawar</span> and <span class=“author-link”>Konrad K Sobon</span> Thank you for your responses. For some reason I didn’t get any notification that I have got a response from either of you.

Konrad, this is really useful document. But meanwhile I switched to Python script for reading the Excel files, which was more straight forward for me.



I feel the same way. That’s why Bumblebee is written in Python. Feel free to double click on any of the bumblebee components to see all of the python code inside. :slight_smile: Have fun!

Fantastic! Sure will do.

Hi I use version 9, and receive the same problem. HRESULT: 0x800A03EC :frowning:

Also tried Bumblebee but receive “Null”

Panie Jurku,

Prosze zamiescic pliki, zdjecia razem ze swoim pytaniem. Brak tak podstawowych danych uniemozliwia nam odpowiedz na pana pytanie. :slight_smile:


I am sorry if I have falsely assumed that you will be speaking Polish just by looking at your last name. In case that you do not speak Polish, all I am asking is that you post a sample file/images of the problem causing definition. Lack of thereof makes it impossible for anyone to answer the question.


I am getting the same error as above. Has anybody figured out a solution for this?

Hi Dago,

You forgot to add “File.FromPath” node after “File Path”.

Guys, the original question was answered. The follow up questions should start a new thread. Now we have two questions and two correct answers but only one can be awarded. Please ask OP’s to start a new thread for questions like this.