Excel read from 2010 issues, Dynamo/Revit

Hi all,

Attached is a recurring problem that we are having reading data from excel.

Running Dynamo 1.2.1 in Revit 2017.0.1099 with excel 2010

In the build that I have even the core read excel nodes are not reading the data, within our team the same set up with dynamo 1.1.0 reads the core read excel nodes.

The definition attached has both lunchbox and bumblebee read options that do not read the data under any build.

Github suggests that it is an issue with Revit and a comment that the next release of Revit will address this, this date was towards the end of 2017.

Can I get some feedback as to whether this is a common issue, it is a significant one for us on our planned workflow.

As a footnote paths seem correct.



Read_excel.dyn (14.6 KB)
Simpleexcel1.xlsx (8.9 KB)

Just curious: couldn’t you use the last Office softwares through a 365 subscription? It’s really worth it, I think…

Business uses office 2010, we have 96,000 employees

1 Like

Hi @Kenyon_Graham

Similar topic is discussed here Excel Nodes Fail Dynamo 1.1.0

@john_pierson was also using excel 2010. Hope it helps!

1 Like

Thanks Kulkul, I did follow that thread, we have quite restrictive privileges which makes even simple system amendments problematic.

Some of the team using earier dynamo versions have managed to get the basic read excel operation to work successfully. Frustratingly I did manage to get Bumblebee to work on one occasion. It appeared an intermittant issue more then a persistant one, its now persistant for all users wrt to Bumblebee and Lunchbox.

I’ll remove key 1.8, however there is a discusion on Github that mentions an apparent Revit issue, how in ever @john_pierson managed to track the issue down to skype is beyond me, he must of been hunting a truffle.

Again thanks

1 Like

Hi Kulkul,

Brief update wheels at AECOM turn slowly:

Removed 1.8 from the registry. The basic excel read functioned as expected both Lunchbox and Bumblebee failed to execute … null values. Quite disappointing.


@Kenyon_Graham Did you tried unblocking dyn and xls file?

1 Like

Hi Kulkul, there is no option to unblock possibly as the file was generated on the pc, I dont have dynamo at home so can’t try it with excel 2016. My feeling is it that it is a Dynamo/Revit issue as I did get bumblebee to run once from excel, just having trouble replicating it.

Its not an isolated incident I have installed dynamo revit on six grads pc’s all have the same issue with the same build.

thanks all the same


You mentioned Bumblebee on more than one occasion. Can you please post screenshots of errors that it produces? Also, if it just returns a null value, please double click on the component itself and copy/paste the Python node from inside that component onto the main canvas. Wire it up like you would the custom node, and see what the yellow error bubble says. I need to know where it fails to be able to help.


Thank you Konrad for getting back to me:

I have attached the bumblebee definition and excel sheet:

  • Read_excel_Rev_A.dyn

  • simpleexcel1.xls

As indicated screenshot of the error associated with the python node line 20.

Read_excel_Rev_A.dyn (10.5 KB)
Simpleexcel1.xlsx (8.9 KB)

All a bit intriging now, my Python is relatively basic, I note the Readit input has changed from Readme



@Kenyon_Graham Try this Read_excel_Rev_A (Kulkul).dyn (10.1 KB)


What was the fix?

Hi @Konrad_K_Sobon

Nothing mate it is same script just that luck it worked for me :smile: just kidding.
I copied and pasted same script in other node and changed to manual :wink:

Hi Kulkul,

Tried your suggestion with the New python node however I get a similar result line 20.

I also tried using a google sheets …sheet to contain the data still no luck.

Additionally I attempted to write from Dynamo using bumblebee to excel to but same result

I did get BB to work with 1.1.0, so will back track and reload an earier version dynamo.

Still no further forward I should say that its not just my build set up that causes the issue we have it deployed on 6 other pcs.

I also had issues with Lunchbox however and only the basic read/write seems to function. Thanks for your input really appreciated.

Hi Konrad, it appears that the issue with importing excel data was …well relatively simple. The excel columns were gerenarated using an expression A14=A13-7 as an example, subsequently dragged into other cells. The null values were generated from the expectation of a number when in fact it was a string and vice versa…Lunchbox also did not like the excel date either… I suppose we learn. There wasn’t an issue with BB.