Element not valid in the workspace

Ok, I know, I’m asking too much but I need to help to udnerstand why is not working. Maybe I’m just tired.
I’m able to extract some solid and points of intersections between elements. I’m not really interested in the solid now but I think I can solve both at the same time.
I can import the list of solid and points as return values but when I connect points to a simple family creation by point, they’re not valid. I tried creating a point by coordinates manually in the workspace and it’s working.
What I’m missing?

I tried also creating a simple node as a test and is not working

Hi @Cesare_Caoduro3

Could you drop here “dll” file so that we can have closer look at. I can’t find the same node you showed above “Coordinates.IntersectionSolidByCategory” node in your package. But i tested your current node and it looks good.

It works just because I decided to change my mind and separate the node
into two different nodes.
Now you can have centroid points or solid as separate outputs and it’s
Just wondering why wasn’t working with a Multireturn output.

@Cesare_Caoduro3 Is it possible for you to drop dll file?

I’ll publish DynaTools on Github within today so you’ll be able to see the
code and participate :slight_smile:

Here it is

the nodes with output as Point or Solid do not work because same warning, do you understand why?