Element.Geometry operation failed


#1

I’ve been running into issues trying to extract slab geometry. As you can see in the image, the slab definitely has geometry to it. However when I run the Element.Geometry (or Element.Solid) node, I get an error saying “Warning: Element.Geometry operation failed. value cannot be null. parameter name: source” What is going on here?


#2

Hi Dennis,

Try using this.


#3

Hi @Kulkul
Thanks for this,

I’ve tried this script and it’s returning a new error:

“Warning: IronPythonEvaluator.EvaluateIronPythonScript operation failed. Traceback (most recent call last): File “”, line 16, in AttributeError: ‘Solid’ object has no attribute 'GetInstanceGeometry” I don’t know what the deal is with this slab


#4

Hi Dennis,

Can you drop here your dummy rvt file.


#5

Hi Kulkul

Here is a file with just this floor slab. I noticed something interesting in the process of making this file that may or may not be contributing. The first picture shows the slab in my project file and the second is the slab in a file by itself. It seems that in my project file, the slab is being cut into creating voids, but in the file by itself it is whole. In the file by itself, the Element.Geometry node actually works ( the python script still throws the same error). I would guess the issue lies somewhere in the fact that the slab is being cut by some objects in the project file

thanks for your help!

Slab_Geometry.rvt (1.3 MB)


#6

Hi @Dennis_Goff - this error means that Dynamo’s surface conversion is failing on this slab for some reason, I’m guessing some of those interior loops are not built how we are anticipating or the slab is very slightly non planar or something else interesting.

We’ll need to use file a bug for this specific geometry. Would you be able to post this to the github page DynamoDS/Dynamo and point back to this forum post?


#7

Hi Dennis,
Correct me if i am wrong your issue is when the slab is being cut by some objects your not able to get geometry?


#8

Yea, at least that is my current working theory. Since the element.geometry node works fine in the file by itself with nothing cutting it I would guess that that has something to do with it. Perhaps there is something irregular about the cutting elements in my project file


#9

Looks like Element.Geometry is failing if you have an interior opening on a slab with an elliptical sketch. Urgg. Sorry, we’ll get on it.


Element.Solids operation failed with complex elements
#10

@Zach_Kron,

This geometry doesn’t have any interior opening, yet the operation for element.geometry seems also failed?

This is Dynamo 1.2

pavilion.rfa (416 KB)


#11

Elliptical interior openings are just one of the known reasons that cause Element.Geometry to fail. It fails otherwise too.

I sometimes manage to get it to work by altering the geometry a little.


#12

my guess here is a conical face :slight_smile: or wacky edge loop, thanks for the .rfa.


#13

I’m bumping this topic. Having the same issue
Any updates on the cause?


#14

Hi guys¡ I have had this problem many times…In my case i have the problem when i select the geometry that u can see on the right side…does any one have a solution?

Thanks¡¡


#15

Hi @JAVIER_FQG

Could you please create new thread and drop your files there. Thanks :slight_smile:


#16

Any update on this? I have a sloping curved roof I am trying to import to dynamo.


#17

Hi guys

Same problem here. Trying to import slab geometry and seems like something is causing problems.


#18

To quote Kulkul:

There are a multitude of reasons this happens and often there is some manor of work around, but without a graph example and the Revit geometry to test we can’t help our much or even confirm that you’re dealing with a bug or just a bad graph.


#19

Parts.dyn (9.2 KB)

I am importing the Parts from Walls into Dynamo and ran into the same issue. I couldn’t see any visible null values yet the error shows up.

P.S: I have tried to upload the rvt file several times and yet it doesn’t show up in the post even after it says uploaded. I am using the “Commercial_Sample_Project.rvt” provided by Autodesk during installation.


#20

I am having a very similar issue as @Rabindra_Adhikari. I am trying to select the surfaces of walls and get this error. Any resoluation?