Dynamo version numbers?

What is the current version of Dynamo? A question came up internally (keeping everyone on the same release version.)

The Help > About shows two sets of numbers, one listing below it, in red

I believe the top number is the version you have installed.
The bottom number is the most current stable build.
It’s red if its more recent than your install.

1 Like

That was the logic we were going with too, but figured might as well confirm it :slight_smile:

So once I have 1.1 for Revit installed, Dynamo Studio 2017 stops working. I see the wiki page says to uninstall and reinstall Studio, which I’ve done and rebooted…twice. Still not working.


@Jason_Parker @DaveP is right bottom is most recent version you installed. Here is how to confirm using Python:

Hi @rcameron- We are officially releasing 1.1 today. It looks like you may have been working with one of the daily builds where we were finding several bugs around install/uninstall.

To ensure uncorrupted builds, I suggest that you uninstall all of your Dynamo components (Dynamo4Revit, Dynamo Studio, and Dynamo Core) using the Windows Control panel. Then, try installing all of the latest stable builds again.

Additionally, please ensure that all Dynamo instances are closed before trying to install another one on top of it. For instance, make sure that Dynamo Studio is not running while you try and install Dynamo Revit. This will cause an automatic reboot of your system and deletion of Dynamo Core. This is a known bug that we are working on.

Let me know if this works for you.

@Jason_Parker- the red number does indicate the current stable build, but we had a bit of time there where 1.1 leaked before the official release. Sorry for the confusion.

Let me know if you all have any further questions or are seeing any more issues during install/uninstall. The Dynamo team is working hard to fix all the known installer bugs.

hmm…I must still be missing something major. I’ve completely uninstalled DS and D4Revit. How do I go about uninstalling Core? Is it anything like this: https:// github.com/DynamoDS/Dynamo/issues/6555

Is there a preferred order to which Dynamo to install first? D4R before DS?

DS Core should be in add/remove programs as a separate entry.

@rcameron- You should see something like this. Remove all the ones in red (you might not see the same version numbers as me)

Hard to believe, but I do not have the Dynamo Core 1.1.1 in this list. Which is weird, b/c I have it under Local Disk (C:)/Program Files / Dynamo / Dynamo Core

How do I install Core 1.1?

EDIT: Let me rephrase this. Only because I’ve done multiple reboots, uninstalls and order of installs.
How do I get Dynamo Studio going again? Just bought it like two months ago… Dynamo4Revit 1.1 is working great. Now I go to the Dynamo Studio site, it says 1.1.0 download available, I download that installer and I get the “Newer version of Core is already installed” error then I guess it “pretends” to install. I go to open DS2017 and it crashes on the load screen.

I’ve removed/deleted/uninstalled everything (short of going into the registry) and even installed DS2017 1.1.0 before installing D4Revit 1.1.0. and visa versa. Problem still persists.

Can you just try deleting that folder, and then trying to install again? Let me know how it goes.

Worst case, you can treat it like just about all other Autodesk programs. After “uninstalling” manually delete the left over folders in \program files, \users<profile>\roaming\autodesk
Then search the registry for entries, deleting anything remotely related to Dynamo.

Then Reinstall!

The registry is where most of the Autodesk products miss, and often source files are left in place.

ProgramData = deleted folder
ProgramFiles = Deleted folder
Roaming AppData = deleted folder
Roaming Autodesk Dynamo Studio = folder does not exist

used this: https://support.microsoft.com/en-us/mats/program_install_and_uninstall
Guess what, it found Dynamo Core 1.1.0 still floating around… then said it “fixed” it. Not sure what it meant by that.

emptied recycling folder

beginning a reboot and install. I’ll edit this post in a few minutes.

OK, hold on. Dynamo Studio is installed and open. Why the heck does this say 1.0 folder here? Should this not say 1.1??? Is the link to download DS saying its 1.1.0 and its really still 1.0.0???

So I have been doing it right the whole time, the link for the download is still pushing 1.0 out??? Even though it says 1.1.0

Not the end of the world. I’ll just go back to 1.0.0 for Revit 2015 and wait for the next couple releases.

I seem to be in the same boat as rcameron.

I removed all verison of Dynamo from my machine, then did a manual removel from all the locations he meantioned:
ProgramData = deleted folder
ProgramFiles = Deleted folder
Roaming AppData = deleted folder
Roaming Autodesk Dynamo Studio = deleted folder

I then downloaded “Autodesk_Dynamo_Studio_2017_UR2_English_Win_64bit_dlm.sfx” and did a clean install of Dynamo Studio 2017. This gave me version 1.0 with an option to update to version 1.1 via the grean cloud. However when I hit the green cloud nothing happens, it just closes Dyanmo Studio?

My running Windows 10 on a 64bit laptop if that matters.

Hey Carl, its Ryan Cameron. Been about a minute since I’ve seen you. :wink: I have like 3 accounts on here. (home, work, random)

My little green cloud worked!!! I’m on Win7 - 64bit on a desktop. That makes me think its OS related for you or the fact you downloaded UR2. Should be UR3, or at least it was for me.

This is a very, very different install process than the last few days I’ve tried. So far, it works for both D4R and DS! I’m pumped!

So: get DS-2017 updated first, then manually download the Dyn4Revit 1.1.0 before you ever open DS2017. Install D4R 1.1.0. Do not open revit and try Dynamo to wait for the green cloud in it, manually download it and install.

Open both to test. Success on my end! Just in time for my Dynamo+Formit360 Block Party in Seattle next week!

Thanks @rcameron @CStorms for catching this. We are working on fixing it. More soon.

Please let us know if you continue to have install/uninstall issues.

1 Like

@rcameron Thanks - Whats this Block Party in my old neighborhood about my 2 favorite programs.

We’re conferencing in 6 offices and about 30 to 40 attendees with a special guest speaker and then myself presenting topics in rapid succession in regards to Revit, Dynamo, FormIt360 and the idea of generative design and how it informs our process. Seattle is an amazing place, the view from our office overlooks the waterfront (ferris wheel to ferry station and beyond)

@rcameron @CStorms @Mike_Engel1 - The installer on the Autodesk website has been updated. Please let us know if you run into any more issues.

@rcameron - The Block Party sounds fun. Would it be possible to listen in or hear feedback from that group? Let me know if we can coordinate having some of the Dynamo team join in. Just PM me directly.