Dynamo Studio not working after D4Revit 1.1

So Dynamo Studio 2017 won’t work if you update Dynamo 4 Revit to 1.1? I’ve uninstalled and reinstalled, rebooted…not working still.

What’s up with that?

Have you removed the Dynamo core folder? Could be a conflict in the core portion.

1 Like

Hi Ryan,

Report your issue here https://github.com/DynamoDS/Dynamo/issues/

Hi Ryan, this is part of the known issue of 1.1.0 release which says:

Installing Dynamo 4 Revit 1.1 Will require a reinstallation of Dynamo Studio with Core 1.1 (1.0 and 1.1 cannot co-habitate). This issue will not happen in the future, when Future Dynamo Core installation will work with older versions of Products.

Please install Dynamo Studio 2017 (with Core 1.1) when it shows up for download.

Ah, I see. I didn’t realize I had to remove it manually. I guess that makes sense. Thanks John!

When will Dynamo Studio 2017 have a download available with Core 1.1 - tried twice yesterday and the download is still 1.0 (which means my Dynamo Studio is dead in the water)

It appears the workaround currently will require the following - Haven’t tried this yet, but maybe somebody can confirm.

Un-Install all versions of Dynamo
Manually remove any remaining folder and fragments
Install Dynamo Studio 1.0
Open Dynamo Studio and Upgrade within Dynamo Studio to 1.1
Install Dynamo for Revit 1.1

Hello again Mike! I cracked the code! Are you on Win7 or Win10? It might not matter but apparently that seems to be an issue. I’m on Win7 and I got it to work. I feel your frustration.

@Mike_Engel1 - We have fixed the installer issue. The new 1.1 installer is up on the Autodesk site. Let us know if you have any issues.

Follow up Items / FYI

Downloaded installer from “Account Managment” this one still failed?
Downloaded installer from Studio Website - this one installed
Open Installed Dynamo Studio version and it would not run "core 1.1 was not installed"
Took me to the main Dynamo install page to download Dynamo
Installed Dynamo / Dynamo for Revit 1.1
All appears to be functioning again.


1 Like

@Mike_Engel1 - Thanks for the steps. Did you remember if you were running any instance of Dynamo while trying to install Studio? We have seen a bug where Core will not install properly (and even reboot your system automatically) if an instance of Studio or D4R is running.

Glad you were finally able to install. I will take your comments back to the team. I will look into the issue on Account Management.

Nope, No Dynamo was running and all remaining folders were deleted manually (atleast those I found)

@Mike_Engel1 - Just wanted to let you know that the Account Management page has been updated. Thanks for catching that.