Dynamo text does not show in player

Revit 2021 Dyno 2.6.1
I’m using DynamoText v.2.0.1 and when I run Dynamo it shows the ‘ghost’ numbers in Revit (which is what I want).
However, when I run the same script in DynoPlayer I get no numbers :frowning:
Any idea how to fix this (or if it’s possible to fix)?

Below run using Dynamo

Below run using Dynamo Player

@Alien , hi

hmmmmmmmm… could it be thats the issue regarding CodBlock vs Node?

f.e. a string in a codeblock is not visible in the player, BUT when it is written in a string-Node → Yes



I don’t think Dynamo player generates geometry in the same way as when you run a script through actual Dynamo.

Therefore there is nothing to ‘preview’ in Revit as it’s not generating anything visual in Dynamo (I think).

Your best bet would be to use that package to actually create numbers in Revit rather than just rely on the geometry preview.

Trying using the springnodes node called familyinstance.bygeometry

1 Like





Altho… it makes a number every run. So I end up with n amount of 0… :frowning:

You can throw a unique parameter on those elements so they are easy to delete programmatically.

I’ve just stuck it in another script (that runs just once) instead.