Dynamo script run with errors


I have a script and it’s runs with error can some one help me with this problem.
someone has make this script for me in the past because i don’t know how to make these kind of scripts.
But i need this script for a different project.

I know that this script is created in Dynamo 2.0.3 and that i need the shared parameters to make this script work but it doesn’t work.

this seems like an unfinished script, every node which is light grey on the top is not fully connected and will not do anything

Oke but it did work in the past

Can you describe what the script did in the past?

It would appear that the collection half of the script is completely gone - the part where you tell the script exactly what in the model you want to work with.

What have you tried so far?

If i create i workset like W57_Ventilation the script will get the numbers 57 and put it before the product name. So if i make a ifc of the project i can see witch pipe or something else is created in the this workset. Because some pipes can be used for different applications and with the script we want to separate these pipes

what i have tried is nothing because i don’t have a clue what i’m doing but im going to do a course for dynamo because I want to understand dynamo and how it works

Search the backup folder of dynamo, there may be an undamaged version there
Compare the file date of this script to the ones you find there, if there is a larger file with the same name and an older date in the backup folder you might be lucky

i have looked but i din’t find anything useful