Dynamo Install Broken


#1

 

 

Hello all,

I’ve somehow corrupted my Dynamo install. I’ve tried reinstalling, re-downloading and reinstalling, downloading a previous version and installing to no avail.

Anyone have a clue as to what I need to do to fix it?

Thanks in advance!
Dynamo_Error


#2

Hi Sol,

I’m a developer on the Dynamo team. Could you find a directory called “libg_219” in the Dynamo install location, and tell me the names of all the files there?

Thanks,

Patrick


#3

Hello Patrick,

Thanks for the reply. I’ll do so when I get home from work (Home is broken, Work’s Dynamo works :smiley: ).

Cheers,

Sol


#4

Hello Patrick,

The names of all are as follows:

  • boost_chrono-vc100-mt-1_51.dll
  • boost_regex-vc100-mt-1_51.dll
  • boost_system-vc100-mt-1_51.dll
  • boost_thread-vc100-mt-1_51.dll
  • LibG.AsmPreloader.Managed.dll
  • LibG.AsmPreloader.Unmanaged.dll
  • LibG.dll
  • LibG.Managed.dll
  • LibG.ProtoInterface.dll
  • LibGCore.dll
  • msvcp100.dll
  • msvcr100.dll
That's the lot!

I’ve also tried installing it on both my C: and D: drives (C: being a Solid State 100gb drive, D: being where most of my stuff is)

Cheers,

Sol


#5

Hello Sol

I had such, maybe this helps:

  1. install old 0.7.1 version

  2. grab/copy dll directory in install dir

  3. install new version(0.7.6), add old dll dir to new. And add dll-files from libg_221 and it works


#6

or libg_219


#7

Hurrah! That worked, thanks Ilay :slight_smile:


#8

With the latest 0.8.0 RC build, you should be able to seamlessly work with the standalone Dynamo, even if Revit was installed at any other location than “C:\Program Files\Autodesk”. Try it out and let us know your comments.


#9

Hrm. A quick test (At home) last night allowed me to use it from the Add-Ons tab in Revit, but not as StandAlone/Sandbox. I’m wondering if my registry is corrupted by a prior install as I’ve been having issues.

Any thoughts on how to fix? I’ve deleted the entire appData Dynamo folder (Rhynamo conflicts), uninstalled like normal and reinstalled a few times. Something feels like it’s remaining and not getting taken out that’s causing issues but I’m not smart enough to figure it out!


#10

Can’t get 8.0 rc to open in standalone either. Is there something missing? i can get .75 to open just fine but none of the o.8x builds


#11

Hello Isaac Mensah,

Do you mean you are not able to Standalone Dynamo for 0.8.0 from c:\programfiles\Dynamo 0.8\DynamoSandbox.exe.

I am able to run DynamoSandbox.exe for Dynamo 080

Thanks,

Ritesh


#12

Mine is indeed installed in D: rather than C: - so this may be the problem.


#13

Hello,

I am wondering if this could a be a more widespread issue. I downloaded the 0.8.0 stable release today and starting prepping it for use within our company. On two machines I have tested on so far, DynamoSandbox.exe does nothing at all when opened. No errors, no GUI. One of the machines has Revit 2014 installed in the standard location, the other machine has Revit 2013, 2014, and 2015 all installed in standard locations (C drive.) On these same machines, I see no issue whatsoever with launching standalone Dynamo 0.7.5 for comparison.

Peter


#14

Hello

I back to work with dynamo and currently test special build with states - 0.8.1.976

I found that i don’t need to install dll/libs trick as previous versions. Thanks to your team

I install dynamo to “p:” disk, revit at “o:” disk

(i have 4 physical drives)


#15

Thanks a lot Ilay,

Will make it even better.

Thanks,

Ritesh


#16

I am having an identical issue. A standard download and install of Dynamo 0.8.x does not start, no GUI, no errors. So, what was the solution exactly? Thank you.