Dynamo grid does not appear-revit 2020.1 Radeon graphics card

Dear Dynamo users,

It seems this problem has been posted many times before, but unfortunately i can’t seem to figure out the solution.

The Dynamo background grid does not appear, despite following suggested solutions in other threads such as:

  • changing windows graphics settings: choosing Revit and assigning it to high performance
  • AMD radeon catalyst control centre: from the switchable graphics applications settings: choosing Revit and assigning it to high performance
  • AMD graphics settings: advanced: disabled the AMD crossfire which allowed multi GPU operation
  • updated the graphics card to the latest available version.

I am using revit 2020.1, dynamo version:, on an HP laptop with windows 10 64-bit operating system, AMD A10 -9600P radeon R5, 2.4 GHz, 16 GB RAM.

Any help would be appreciated.

Have you got a 2nd graphics card?
I used to have issues when I did and would have to manually disable one before I got the display to work.

try installing https://www.microsoft.com/en-us/download/details.aspx?id=35

yes i have 2 graphic cards, i already disabled the Radeon AMD Crossfire function that used to allow multiple graphic processors to work together.

i just did…nothing changed

also check the background preview is actually enabled (theres a menu in the menu bar).

yup that’s the first thing i did