Dynamo controlling tags


#1

hey everyone , I want to know if this is possible using Dynamo. In structure design drawings, the beam tags should be in the middle of each span, so one way of doing it is splitting all the beams at the column location or creating multiple tags and moving them manually. Also sometimes the tag is different from one span to the other.

My question is, can Dynamo create a tag , pick the family type based on a condition and then place it in the mid span, say the mid point of the analytical nodes along the beam vector ?

thanks

 


#2

I think that you should start by checking out these great articles by Konrad. His workflow is very similar to what you have in mind:

It should be fairly easy to pick the mid point of the analytical/location line of the beam with “Curve.PointAtParameter”.


#3

I checked Konrad’s workflow, and it’s exactly what I’m looking for, but the <span style=“color: #4c4d51;”>“Create Annotation Tag” package is shown as deprecated.</span>


#4

Konrad’s node is still valid, it just needs to be adjusted slightly for the way Dynamo handles things after 0.7. I hope he doesn’t mind me messing up his node:

2015-01-08_142119

 

TagElements(Archi-Lab)

Create Annotation Tag

Copyright© 2015, Konrad Sobon
@arch_laboratory, http://archi-lab.net

Full credit goes to Konrad. Much love for his amazing work!

 


#5

Thank youuu so much :slight_smile:


#6

Dumb question! Where do you place these nodes to use them? Here–> C:\Users\YOUR_USERNAME\AppData\Roaming\Dynamo.7\definitions ? If i add them there or in the packages, i dont see them in my list even though i restarted Dynamo.


#7

Never mind i got it to work,


#8

Hi, Dimitar Venkov. Could you please share with us what was the slight adjustment that you made? This node still doesn’t work for me, and I can’t find any solution.

 

Thanks!


#9

Hi Mus,

The node was based on an older version of Dynamo, I simply added a few extra bits as described here:


Are you using a list of tag locations, a list of elements and a list of views as shows in the image above?


#10

Hi Dimitar,

Thank you for your response. I have all in lists just like in your screenshot. What draws my attention is the Python node, which gives me this message :

Warning: IronPythonEvaluator.EvaluateIronPythonScript operation failed.
Traceback (most recent call last):

File “<string>”, line 13, in <module>

IOError: System.IO.IOException: Could not add reference to assembly LibGNet

at IronPython.Runtime.ClrModule.AddReference(CodeContext context, String name)

at IronPython.Runtime.ClrModule.AddReference(CodeContext context, Object[] references)

at Microsoft.Scripting.Interpreter.ActionCallInstruction`2.Run(InterpretedFrame frame)

at Microsoft.Scripting.Interpreter.Interpreter.Run(InterpretedFrame frame)

at Microsoft.Scripting.Interpreter.LightLambda.Run4[T0,T1,T2,T3,TRet](T0 arg0, T1 arg1, T2 arg2, T3 arg3)

at System.Dynamic.UpdateDelegates.UpdateAndExecute3[T0,T1,T2,TRet](CallSite site, T0 arg0, T1 arg1, T2 arg2)

at Microsoft.Scripting.Interpreter.DynamicInstruction`4.Run(InterpretedFrame frame)

at Microsoft.Scripting.Interpreter.Interpreter.Run(InterpretedFrame frame)

at Microsoft.Scripting.Interpreter.LightLambda.Run2[T0,T1,TRet](T0 arg0, T1 arg1)

at IronPython.Compiler.PythonScriptCode.RunWorker(CodeContext ctx)

at IronPython.Compiler.RuntimeScriptCode.InvokeTarget(Scope scope)

at Microsoft.Scripting.SourceUnit.Execute(Scope scope)

at DSIronPython.IronPythonEvaluator.EvaluateIronPythonScript(String code, IList bindingNames, IList bindingValues)

 

Does it mean that I’m missing something called LibGNet? Sorry for the basic questions, I just can’t wrap my head around it…


#11

Did you download the node straight from the package manager? That one only works for Dyanmo 0.63 and below.

You’ll need to download it from my post above and put it in the following folder:

C:\Users#your user name#\AppData\Roaming\Dynamo.7\definitions\

Then once you restart Dynamo, it should show in your library under Archi-lab.

 


#12

Hi Dimitar,

Finally had some time to test it. At first I didn’t remove the original node, so I was still running the old one… But anyway, it works now! Thank’s a ton for your help!


#13

Hi Dimitar, should this node function with dynamo 0.8.1?

The output reads as null when setup with your previously attached graph.


#14

Hello Mark,

That node has been updated in the latest version of the archi-lab.net package and should work with 0.81


#15

 

I have now updated the package but still returns null.
Capture


#16

Hi,

Konrad has upgraded the node and now you can skip the step with the view replication. I the replication might be causing the node to misbehave. It’s working great on my side with version 2015.8.15:

2015-08-21_17-27-08

 

 

 

 


#17

Hi Dimitar,

I have updated the latest version of dynamo and removed the view replication but still returns null. Is there anything else you will suggest?

Thanks