Dynamo 3D Workspace and Workplane Not Visible


#1

Has anyone not been able to view geometry in the 3D workspace or view the 3D workplane?

I have checked my View settings to show the 3D background workspace, but modeled elements and the workplane grid are never visible. But when running the workflow in Revit, the modeled elements appear in Revit only. Any Thoughts?


#2

Could you unwrap your view settings from the ribbon?


#3

Is this what you were wanting to see?..


#4

What kind of graphics card do you have?


#5

I have a Dell XPS laptop. Appears to have dual graphics, Intel HD Graphics 530, and NVIDIA GeForce GTX 960M.

I am running Windows 10. Other users in my office with the same laptop have the same issues.

I have tried adjusting settings for which graphics card programs should default to, but never noticed any changes.


#6

Same problem here (please see attached screen shot).

  • I have a Nvidia 210.
  • I’ve just updated to the latest drivers (v342.01) & rebooted.
  • Have verified using dxdiag that DDraw and D3D acceleration are enabled on each display.


#7

Had the same problem, tell the graphic card to b used by revit:

It´s german, but maybe it looks the same at your computer?


#8

I talked to an Autodesk Rep at AU 2017 that was familiar with the issue.

Are you using a dual monitor set up with a docking station? You will want to disconnect the dock before opening Revit and Dynamo. Open Revit and Dynamo, you should see the background preview. Then, reconnect the dock for dual monitors.


#9

Thanks for the reply Johannes.

I’ve manually added Revit (see screenshot). All the defaults are “Use Global Setting”. I’m slightly confused, in that surely this is the default anyway, for an unlisted application?

The other thing is that you have 3 sections in your 3D Settings dialogue. You have an extra section in the middle, presumably to select the graphics adaptor?

(I have two graphics adaptors, but they are both the same make/model.)


#10

cdilworth, thanks for your input. I don’t have a docking station per se, but I do have multiple monitors.

I have two graphics adaptors (2 screens connected to one, 1 to the other – identical NVidia cards).

Do you think this might have any bearing on my problem?


#11

It’s possible…Have you tried disconnecting the monitors, and starting and running Dynamo/ Revit on the single laptop monitor? Maybe, reboot the machine once disconnected from dual monitor setup…and after configuring settings back to single monitor use…

When this had happened to me, I was always trying to use Dynamo while set up and connected for dual external monitors. Once I disconnected, rebooted the machine, and started Revit and Dynamo using the single laptop monitor, everything showed up. I was then able to reconnect to my docking station for my externals, and the background preview remained visible.


#12

Someday I hope all these issues go away…

Can you confirm which card you have beyond “Nvidia 210” as manufacturer and model will mean something here.


#13

@Alien Upon PC startup, enter the BIOS and set the hybrid graphics from Automatic to Disabled. Or post a pic here for some extra advice if it doeant look like that. This should force the system to just use the dedicated GPU and your previews should be back. This works on my HP Z Book.


#14

It turns out 2 graphics was the issue.

If I disable one before firing up Dynamo it works. I can then turn it back on afterwards. Very irritating but at least I’ve got my Dynamo background!

Thank you all :slight_smile: