Dynamo 2.3 Slow and Unsuable in Revit

Dynamo 2.3 Suddenly became unusable. Cant place nodes, when I open graphs I only see the wires with no nodes.

Dynamo Player still works but I can’t just build new graphs and all… I need help, I miss dynamo

@Michael_Kirschner2 @JacobSmall People keep coming up with the same problem. Maybe a good idea to make a topic and pin it with a title that contains something like “See the wires with no nodes? Solution here!” Then people will stop posting the same thing over and over again. And if it’s not one solution then you could make at least a series of steps that people can take that could solve it. And if it still not helps then post in that topic specifics. Just saying.

Try to remove Archi-lab 2020. It helped me.
With Archi-lab 2019 works ok.

Okay, would try that

Uninstalled and Restarted, Same thing

If you have dynamo 2020 and 2019, try to remove in both. In my case, if I installed the package on the 2020 version, the 2019 version did not work :confused:

Ive got only Revit 2020 Installed with Dynamo 2.3

please see this thread:

whoops - wrong link - updated now.

The crux is that there was a conflict with system.window.interactivity when both an addin and Archi-lab.net were installed.

As a workaround try removing the offending addin (if you can identify it) or try removing Dynamo’s system.windows.interactivity.dll

3 Likes

…or try removing Dynamo’s system.windows.interactivity.dll

What are the consequences of this removal?
Should we wait for a hot fix from Autodesk? Or we need to say goodbye to our favorite add-ons or packages? :disappointed_relieved:

I had the same problem on Dynamo 2.2 and Revit 2019
“Fixed” it by removing all dynamo and core installs, files from appdata, and clearing my pc with ccleaner. After that just reinstalled a fresh copy of Dynamo and it worked

Done this and it worked. Would I have to go to every machine to remove this. There has to be a fix. And certainly waiting until the next Revit Update isn’t just right for issues like this.