Dynamo 1.3.4 & Dynamo 2.0.2 head scratcher - Not playing nice together?

Hello,

I’m working with a Dynamo graph for a project. The project team would like to be able to use the graph to setup their projects in Revit 2017, 2018, and 2019.

I have Revit 2017.2.4, Revit 2018.3.2 and Revit 2019.2 installed. I also have Dynamo 1.3.4 & Dynamo 2.0.2 both Core & Revit installed (also Core 1.3.2 for Dynamo Studio).

The graph was created in Dynamo 1.3.3 and worked as expected in Revit 2017, 2018 & 2019.

However, when Revit 2019.2 installed Dynamo 1.3.4 the graph stopped working in Revit 2017 & 2018.

The graph works in all 3 versions of Revit if Dynamo 1.3.3 & 2.0.2 are installed.

The graph will also work in all 3 versions of Revit if JUST Dynamo 1.3.4 in installed.

However, if 1.3.4 & 2.0.2 are installed at the same time the graph will only work in Revit 2019?

The graph does include custom packages.

The graph takes advantage of the Data-Shapes package, and when it doesn’t work it just skips over (does not initiate) any of the 4 pop-up windows. I also receive a non-printable character error, which is not an issue in the working graph (my guess is the error may happen because there is no Data-Shapes input because of the missing pop-ups).

After I cancel out of that error I get an Unhandled Exception error from Dynamo.

The graph completes with warnings, but nothing actually happens.

Because of project NDA I’m not able to share the dyn.

2019-01-28_15-11-53

2019-01-28_15-15-27

Can you show some dynamo screenshots with errors?

Okay I will give it a try.

Here is an image of a Graph I did for BILT NA, but I got it to show the same issue.

With Dynamo 1.3.4 & 2.0.2 installed this is the result after the graph has been run. Also note that no Data-shape dialog box appeared.

@CStorms Can you try deleting the UI.MultipleInputForm ++ nodes and replace them?

Now if I uninstall Dynamo 2.0.2 (so just Dynamo 1.3.4 is installed now) and run the same graph it runs just fine.

The First image is the Revit file before the graph is run.

Then I run the graph and the first of two Data-shapes pops-up

Then the next pop-up appears

Then the graph is complete and the selected furniture has been rotated as shown in this image.

I have also attached the sample graph (dyn).

The Revit file is too large, but it is just the out fo the box Revit Advanced Arch Sample project.

Rotate_T2_Done.dyn (14.2 KB)

Can you try installing Dynamo 2.0.2 and replace the UI.MultipleInputForm ++ nodes as my previous post?

@salvatoredragotta Yes I just did that and the outcome is the same, the graph still does not work, still no Data-shapes pop-ups

@CStorms I cannot replicate the issue. It works for me with Dynamo 1.3.4 (and Dynamo 2.0.2 installed)

@CStorms - can you confirm which version of the datashapes nodes you’re using? Also are there any errors showing in your console (bring the mouse right above the charcoal bar at the bottom of the UI and drag up).

This feels as if something is sidelining the datashapes functionality (namespace collision? perhaps an issue with a security setting?) @Mostafa_El_Ayoubi may have some insight here.

Hi @CStorms,
Can you show what comes out of the ui ++ nodes?

1 Like

@JacobSmall I have version 2018.12.1 of Data-shapes installed

There is LOTS of stuff in the console, only a small amount shows up in the picture.

Hi @Mostafa_El_Ayoubi you can see what’s coming out of the ui++ nodes in the image below. Let me know if you need a better picture.

@salvatoredragotta thanks for testing this, the fact that it works for you and not me just adds to the head-scratching.

Thanks again for helping out!

1 Like

Copy/paste it? PM if you’re worried about proprietary stuff.

PM sent

What is the path to your Dynamo for Revit 1.3.4 package directory, and your Dynamo for Revit 2.0.2 package directory? (you’ll have to check in two different Revit instances to know).

1.3.4 = E:\ZZ_Dynamo
secondary 1.3.4 = C:\Users\cstorms\AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages

2.0.2 = E:\ZZ_Dynamo_V2_0
secondary 2.0.2 = C:\Users\cstorms\AppData\Roaming\Dynamo\Dynamo Revit\2.0\packages

1 Like

Step 1: Confirm the drive is mapping correctly.

Step 2: Make sure all packages in the E:\ZZ_Dynamo
secondary 1.3.4 ( = C:\Users\cstorms\AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages) are built for 1.3 (open the dyns where possible). Then attempt to open in 1.3.4 and then then 2.0.2.

Step 3: Disable all add-ins in Revit and try both a second time.

Thanks @JacobSmall

I removed my pyRevit (4.6.12) add-in from Revit and that did the trick.

While doing that I also found 3 packages in my 1.3x Packages folder that were made for 2.0 and removed them as well.

Forgot to add the sweet little graph @JacobSmall shared with me to be able to check what version of Dynamo the custom packages I had installed were built on. It runs in Dynamo 2.0

What Package Engine.dyn (14.1 KB)

Capture

Thanks for your help!

3 Likes

Very glad you got it fixed! :smile: