DWG Structural Steel to Revit + Fireproofing

I’m trying to bring structural steel into Revit and then use Dynamo to add fireproofing around it. Here is my process so far and what it produces:

I import the DWG into a generic model family.

I load the family into a project.

I run this:










As an example - this piece of steel looks like this before and after:

Image_02 Image_03













At the least, I would like to fill in the corners so it looks more like a coat of fireproofing instead of just thickening of edges. If possible, I would like to get rid of the extra small surfaces and clean it up to be a single “coat” all the way around each steel member. Here is what it currently looks like and what I would like it to be:














Any thoughts would be appreciated.


I guess you’ve already seen this:

Consider the following alternative:

You can find “Geometry.SplitRecursively” inside spring nodes.

1 Like

Thanks for the help Dimitar. I did see that blogspot link you posted, and I can get this to work with Revit structural elements. The problem is that we’re getting structural files from CAD or Tekla in DWG format. I need a way to bring the DWG 3D content into Revit and then get the same result you got above.

Using a piece of your example, I tried it as shown below. This actually gets me pretty close. It worked well enough on the smaller steel - putting a 2.5 inch thick box around each piece. But it didn’t like the complex shape of the actual beam and gave me an error.

Oh wow this would be very useful. would there be a way to remove the fireproofing from the top portion if the member if it is a beam?

I get an error that the last code block is over indexed. Suggestions??

David, I won’t be able to help you further without an example file. Also you don’t seem to be following my example. Are you not getting a solid from “Element.Geometry” ?

Michael - it should be quite easy to achieve, you just have to perform another cut with a plane at the beam solid’s top-most extent.

Tom, it looks like the node is not working for some unknown reason. Maybe deleting and re-installing the package will help?




Tried that. Still getting same error :confused:

Have you guys made any more progress on solving this?