Duplicate familiy types from linked file

dynamo

#1

hello, i’m new to revit and dynamo please let me know if i misunderstood how revit works or there’s workaround.

I’m trying to compare family type with a linked file, which is a updated version of an old model, and set up new family type by duplicating the difference if there are missing types compared to the linked file. For instance, if a beam family type with type name 300x500 is included in the linked file but excluded in current file, i would like to identify it automatically and create the type in current file with all parameters (b=300, h=500) all set up.

What i have done by far returns null, i suppose it’s the last node that’s not working, is there any packages that can do this?


#2

Hi @brian3814,

The “spring” package can be really useful for you.

I just made a little experiment here and it worked great, I’m almost sure it would solve your problem.

Durmus.



#3

Thank you for your help, didn’t knew there’s a node that can copy directly from the linked file, it really helps.
But judging from your experiment, it seems to me that elements are also copied into the current file, right?
Is there any way to just get the family type? Like if i run the script in a totally new project, I want all the family types set by copying from linked file but still no elements are drawn in the current file during the process, either with ootb node or python.


#4

ohh~ i just find out after posting that this node can take family types as input as well, that’s silly of me!!
your legend, thanks a lot!!


#5

@Durmus_Cesur
Sorry for bothering, but one more question.
my current workflow to get family type is select all elements and get unique family type by using duplicated item indices node, this might be expensive since i have thounsands of elements, is there a much more efficient way to get the list of all family type in the linked file? i 've tried approaches below but keeps returning null.


#6

Hi @brian3814,

I know you can’t use “Category” and “Link Doc” together. As you have already seen, you have encountered an error and I suggest you not use 2 together.

I’ve improved the code a little.

1-Not in the project, “Link” you create the elements of the project you create.
2-In the project and “Link” allows you to filter the elements in the project you are doing. In this way, it avoids possible collision errors.