Downgrade from 1.3 to 1.2?

We have 1.2 installed on all the office machines.
I (main Dynamo developer in the house) have upgraded to 1.3 on my computer, but I still need to maintain the old graphs.
I tried to uninstall 1.3 and re-install 1.2, but the installer refuses to install 1.2.
It tells me that I already have a newer version installed, so it won’t install Dynamo Core.
I have run the Windows uninstaller and manually deleted every “1.3” folder I could find, but I still can’t install 1.2.
There are FAR too many registry entries to manually delete.
Is there any way I can downgrade?
(And, no, I can’t just use 1.3. Some of the packages have changed and nodes have been deprecated & are unavailable)
We have 160 installations, so upgrading the entire office won’t happen for a while, either. Especially not until I fix everything that broke in 1.3

Go to control panel and uninstall Dynamo core as well

That’s what I did.

well shoot. Maybe reinstall 1.3 and use IOBit Uninstall Utility. It does really clean uninstalls

1 Like

Great tip, John! Thanks:+1:

IOBit didn’t quite fix the problem, but at least it identified it.
Turn out it wasn’t 1.3
IOBit showed me there was a 1.2.1 Dynamo Core installed, and I was running the 1.2.0 installer.
So, yes, a newer version. Just not the newer one I assumed.
No idea why 1.2.1 didn’t show in the Windows Control Panel uninstall, though.
Not only that, but even IOBit couldn’t clean it completely. I had IOBit uninstall and even delete registry entries and I still couldn’t install 1.2.0.
Finally ran the 1.2.2 installer and it was happy.

No wonder my brain hurts this week.

At least in is Friday and National Donut Day :doughnut: :smile:

1 Like

Worked for me!
Revit 2019 and Dynamo was awful at this time!
downgraded to 2018!