DataShapes (2021.2.94) - SelectModelElements Data - Invalid Input

So I’m getting a warning on the nodes (SelectModelElements Data and SelectModelElements Data (ordered)).

The warning says:
"
Warning: This custom node contains an invalid input. Please fix the input before saving the custom node.
"

error -node

I have read some posts about the input being wrong, but still can’t figure out the issue. Editing the custom node the input causing issues says:
"
Error: This input symbol is not currently valid, and cannot be saved until it is fixed. Valid inputs take the form:

name : type = defaultValue

The input name should be a valid variable name, without spaces. An input type and default value are optional.
"

error - input

Right now the input is:

CategoryFilter: var = “”

I haven’t used DataShapes in awhile, but I think the last time I used it this node had a category filter on it. So maybe I’m just not understanding what this should be doing.

Do you have the latest version of the package installed?

Yes. Latest version is installed.

I tried uninstalling and reinstalling to see if that could possibly help. It didn’t.

The appear to be ok in the latst package

1 Like

I have the latest available version installed in the package manager.

Oddly though I installed it on my work computer and it worked. Can’t figure out what is different between the two. Both have the same version installed.

Do they both have the same version of Revit and Dynamo as well?

No they aren’t.

The computer not working is Revit 2021 (21.0.0.383 | 20200220_1100(x64)) and Dynamo (Core: 2.5.0.7460 | Revit: 2.5.0.7586)

The computer working is Revit 2020 (20.1.1.1 | 20190731_1515(x64)) and Dynamo (Core: 2.2.5175 | Revit: 2.2.1.5291)

So I’m still having this issue.

Weirdly I did uninstall and reinstall Revit and it was working for a about a and then my hard drive failed. So new hard drive and I just reinstalled Revit 2021 again and I’m back to the same error.

Now though I have Revit 2021 (21.1.1.109 … 20200715_1022(x64))
And
Dynamo (Core: 2.6.1.8786 and Revit: 2.6.1.8850)

I know the DataShapes packages says it was only tested with 2.5 so I’m not sure if that is part of the problem.

I guess I don’t understand the error:
"
Error: This input symbol is not currently valid, and cannot be saved until it is fixed. Valid inputs take the form:
"

I’m not sure if the error is with Dynamo, the code, my computer, the install, Revit, or something else.

I know that I’m not providing any attempts to fix this. I’m just at a lose as to what is going on.

If I change the Input name of ‘Category’ filter to something else. The node is fixed and it runs, but it doesn’t return the selection of elements.

I know the Input is named what it is for a reason. Just trying to figure out why I’m getting this error.

I also went through all the datashapes nodes to see if there were anymore issues. I found the following have the same error. The Input would be named something different depending on the node.

other data shapes nodes

I also went through and deleted all other packages (besides the Generative Design installed with Revit/Dynamo) hoping there might be some sort of conflict, but that didn’t fix it either.

Just to reply to myself, wanted to provide how i ended up “fixing” this.

I uninstalled all other packages, I installed and reinstalled DataShapes a handful of times, closed/reopened Revit, and did a computer restart a few times. I’m honestly not sure which of these steps fixed the problem, but the nodes are now functioning.

Not a great solution since I don’t know what really fixed it, but wanted to provide some details on what I did in case someone else has this issue.

DJ,

this happens to me several times, on some custom nodes, I do not remember what package exactly.

The issue for me was that the text used in the Input node was also a restricted keyword for pyton, or design script, not sure which.

Once I rename the input string (sometimes even changing from capital to small cap helps) the custom node works as expected.

Not sure my case applies to yours, but it looks really similar.

regards

gio