Data-shapes Unexpected Error

data-shapes

#1

Hi there,

I am using the data-shapes package and since a few days I get a very weird error:

Surprinsingly, when I hit Weiter (continue), the form stays open. If I hit Set Values again, same error.
However, when I hit Weiter and then QUIT the form, the script works as expected.

What am I doing wrong?

Here is the complete error log.

This is the error description in English (found somewhere else as an image, so no paste available)
image

And here is the paste of the original error in German.


#2

Can you paste the contents of the error description as well? Typing into translate isn’t a strong point for me.


#3

Hi Jacob, not sure about the meaning of this, but I’ve included a paste of the error description that’s on top of the window.
The whole error log was already available.

Thanks.


#4

Hi @pierremonico

What’s your Revit language?


#5

Hi @Kulkul

German.


#6

Try changing Revit language to english and run your script.


#7

Error log is here.


#8

Was it working fine before?


#9

Was referring to the error description on the top of the window - Tried retyping from the image but it wasn’t working as I wasn’t reading/retyping well due to the language being unfamiliar and autocorrect trying to make it all English. I would say you’ll need to remove the datashapes package from your library, close dynamo, close revit, confirm all datashapes folders are gone in your package directory, restart revit, restart dynamo, and then reinstall the datashapes package via package manager. Are all your packages local (on your computer) or are they networked?


#10

Unfortunately yes, so I have no clue why it stopped working all of a sudden.


#11

Actually I already did that twice, but I might try again and install an older version. Thanks for the suggestion anyway.

We have a quite complicated system, but since my environment itself is on the cloud, it works like this:
I am connected to a “cloud computer” on which Revit is installed. The package files are on this same computer.
I already talked to our IT department but you know the deal right? :slight_smile:


#12

That I do. Try the older version.

Multiple paths under manage node and package paths could be causing dynamo to see datashapes in multiple locations, which may cause odd behavior (but I’ve never seen this).


#13

what version of dynamo is this?


#14

Ok I’ll check that, thanks.


#15

1.3