Data-Shapes UI - Script was working, now does nothing

So, I’ve been working with Data-Shapes for a few hours. I had this script working fine. Tested it a handful of times. Now when I click run, it just says “Run completed” in Dynamo, but no UI comes up and nothing happens in the script.

I closed out of Revit and Dynamo, still doesn’t work. :-/

Restarted my PC and reinstalled Dynamo. Still doesn’t work.

When I run the script, it also acts as if I have changed the script. The asterisk comes up beside the filename and it asks if I want to save when I close.

Went back to the original version of the script before I added Data-Shapes UI to it. That still worked, so I copied and pasted the DSUI portion into it and wired it all back up. That version works.

I have no idea why the new one works. It looks just like the old one.

I’ve had similar problems before but they were probably back in 0.9. Seems like maybe something got corrupt in the file definition. Recreating the graph like you did is probably your best option. Sometimes I could copy/paste from the broken file and sometimes I couldn’t. Maybe someone else has more information.

Yeah, only thing I can figure is some of the things I was experimenting with in that file and then deleted because it wasn’t working left some corruption behind.

Lesson learned: Save As before experimenting with a working script! :smiley:

Glad to hear that that solve it for you. This is how i prevent that problem :slight_smile:


1 Like

LOL! That’s awesome! :smiley:
I’m new.

Sometimes deleting the backup files will clear out the corruption as well.

1 Like