Data-Shapes Crashing Revit


I am trying to use UI.Listview Data to select a level. The dialog box pops up, however when I select set values Revit crashes. I have tried re-installing multiple versions of the package and I’m using Dynamo 2.0.1.

Has anyone had this problem before ?


Have you tried the same values with the UI.DropDown input? Or any of the other inputs? Just to check that the Multi-form section is functioning.

Also, note the following comment for Dynamo 2.0

Yep, I’ve tried multiple different inputs and also tested Data Shapes in Dynamo 1.3.3

try to install latest Microsoft .NET Framework

Hi everyone,
the latest version of data-shapes is full 2.0. What version are you using @mgreenZU2SB?

1 Like

Hi @Mostafa_El_Ayoubi,

I’m currently using 2019.2.1. I have uninstalled and tested it with older version as well.

Hi @khuzaimah.ElecEng

I just installed the latest and I’m still having the same issue.

Can you delete whatever happens after ui. MultipleInoutForm++ and give it a try? Just to make sure the issue is directly linked to the form…

I’m getting the same problem.


Hi !

Do you have any idea what the problem could be? I’ve tried different scripts, different versions of Dynamo and Data Shapes.

Can you close Revit, open a new instance of Revit, open a blank project, open the graph with just the UI++ content which triggers the error, run it, let Revit crash, a d then provide the Revit journals and Dynamo log files for review?

1 Like