Data-Shapes TreeView FirstItemIsTitle not working?

Hi,

I’m wondering if I’m missing something with how I’m trying to use the Data-Shapes TreeView node. I have the node set with FirstItemIsTitle set to true and I have item 0 of my list as the Title so I’m not sure why the title still showing up as List1, see below. Any help seeing what I’m missing would be great! Or if it’s unavoidable at least I’ll know to give up!

Thank!

Package version 2019.2.42 dynamo Revit 2019 2.0.4.12685

image
image

Try flattening the list.

Thanks, unfortunately the data-shapes output didn’t change after flattening the list.

I think you need to transpose the list first so you have a list of “titltes” in index 0 for the node to use as titles

Thank you for the suggestion. I just tried transposing it every which way and unfortunately that didn’t change the output either.

Is this part of the UI.TreeView just not working anymore? I can’t find any examples of the treeview node including on the Data-Shapes website.

Hi everyone,
Still no solution on this topic ?

@Mostafa_El_Ayoubi any thoughts?