Data.ImportExcel operation failed. Excel is not installed

Dear All,

I am using Revit 2020, Office 365 & Dynamo 2.3.0. Excel is 64 bit.

While running dynamo graph which needs to refer data from excel. I am getting warning “Data.ImportExcel operation failed. Excel is not installed” .

I searched on forum regarding this issue but i am unable to solve,

Kindly advice.

Thank you.

In Office 365 there is an option to install Office Apps on your local drive.
Give it a try.

Hello Marcel,

I checked with our IT guys, he confirmed that ‘Office 365’ in already installed on local drive.
Any other suggestion?

Thank you.

Does the bumblebee package work?

Just i tried with this package but output shows null.
Below image for your reference.

Thank you.

Have you started excel locally without issue?

Hello Jacob,

Actually earlier ‘Data.ImportExcel’ node was working well.

But now IT has installed ‘Office 365’ on my system & then onward I am facing this issue (My colleagues are also facing same issue after installation of ‘Office 365’).

After installation of ‘Office 365’ I able to open excel without issue.

Thank you.


Try to repair Office 365, it worked for me and my colleagues.


1 Like

To @Alban_de_Chasteigner’s point, this is almost certainly a failure that stems from a bad installation, likely causing an issue in the registry related to interop. A repair should help, but you may need IT to clean the installation entirely and try again.


Hello Jacob,

Our IT guy uninstalled ‘Office 365’ then deleted registry key as well & then install ‘Office 365’.
Now Excel working properly with Dynamo.

Thank you for your advice.


Dear Alban,

I tried this but no luck.

Thank you.


We have had a similar problem of not being able to connect to Excel (Office 365) from AutoCAD 2022 and Revit/Dynamo 2022. We’ve found that this will work until we install Navis Manage 2022/23, at which stage, the installation of the Microsoft Access database engine 2016 component will trigger the problem in AutoCAD and Revit/Dynamo.

Unstalling Navis and the database engine do not solve this but excluding the installation of the database engine in the first place on a clean PC does. This can be done as mentioned in the post below -

Microsoft Office 32-bit products become unusable after installing Navisworks Manage/Simulate 2022 | Navisworks Products 2022 | Autodesk Knowledge Network

Repairing Office does fix the problem but we’d rather it didn’t occur in the first place as future updates may resurrect the problem.

Hope this of use to someone.