Data.ExportExcel operation failed

Dynamo is falling over trying to write to an Excel file. All of my inputs to the Data.ExportExcel node are ok while this node only shows null as the output. Kindly see error message


You can try installing or reinstalling Excel

Hi @Marcel_Rijsmus, I figured out the issue on my end. Some of the data I was exporting to excel were strings that started with = sign. I added a ’ to the start of these which resolved the issue.

I’m hijacking this thread to just give another possible solution. I had the same error message, but a different reason for the error. In Dynamo I was pushing a SUMIF formula to Excel, the different parameters separated by semicolon. This didn’t work because of the equal sign - or so I thought. Actually it was the separating semicolon that was the culprit. I changed it to a colon and now it works, and for some reason it changes the colon to a semicolon when it writes it to Excel.

The string in Excel looks like: =SUMIF(‘Golv & tak i Revit’!A:A,@A:A,‘Golv & tak i Revit’!G:G)
and in Excel it writes out to: =SUMIF(‘Golv & tak i Revit’!A:A;@A:A;‘Golv & tak i Revit’!G:G)
Just for anyone else running into this issue. I’d think it’s connected to the regional Excels using different ways to write formulas.

1 Like