Creating floors from rooms

Just wondering if anyone could help with this -

I created a dynamo script to create floors from rooms in Revit - I’ve tested it several times on basic models, with just a couple of rooms in and it’s worked fine, but when I try it in a current project it just won’t work - the problem seems to be in the ‘create floor geometry’ section. The images show this when run in a test model and then run in the current project model. Has anyone got any ideas on where I’m going wrong? Thanks!





In your project environment the rooms are probably not at 0 level and doesn’t intersect the XY Plane

Ensure that the XY Plane intersects the rooms by translating it upwards along the Z Axis.

Later, you might also want to consider flattening some of your lists.

Further to Vikram’s response, this might help

Note the bit about complex boundaries, such as a room bounding internal object/double curves.



I tried something similar when trying to run this script on a larger model, at my testing model I worked fine, but at the larger model It only created some of the floors.

Only one picture pr. post because I’m new…

I set a filter on the floor type created, and this is how it looks in the model, some of the floors is created but not all of them - in the hole model 20% are missing my created floor.

Did you make sure that all rooms have a floor finish specification, and that the name of that floor finish matches the name of the floor type?

The Floor Type does not need to match the Floor Finish, that’s for me to decide, if you understand what I mean - but yes, all floors have in the Floor Finish parameter a name like on the above pictures.

This is how it looks now

Hi. Thanks for sharing the topic. I also would like to create floor to room for all levels. However I only got floor at level 0, whatever level I chose. Can you help me?

Hi @helenaSQQ8Q

Could you please create a new topic for your query? Thanks :slight_smile:

@Emma_Kirk Could you mark this post as solved if your issue has been solved, so that we can close your topic. Thanks :slight_smile: