Create Shared Family Parameter -DanEDU

I updated DanEDU to version 2018-115.0, and now the set formula node works like a charm, BUT the FamilyDocument.CreateSharedParameter node doesn’t work as before. Specifically I have a list of 7 parameters that I create but it puts everything into the first parameter group in the list.

Thanks Tim

You’re missing first input family document.

@tvaughn,

From what I can see, it should work. if a document is not provided, it will take the current document. so it is fine that this port is not attached to something.

What I do see is that the package is outdated, please update to the newest version.

Could you please upload your .dyn file? and preferably also your shared parameter file, so I can try to figure out what the problem could be?

Create Door Family Parameters.dyn (13.1 KB)
FHAI_SharedParameters.txt (127.0 KB)

I have package 2018.115.0 installed. It’s not a huge deal because I just split them into two loops in another script, but was just curious why it wasn’t going to the correct parameter Group.

I just tried changing the lacing to longest and now everything works fine. It must have been because my input lists were different lengths.It would read all my parameters, but for the parameter group it would only read the first item. Same thing when I tried using the SetFormulabyName node.

Now, since I solved my own question, do I get credit for that or is that cheating? :slight_smile:

I think it is good that you solved your own question, so you should credit yourself :slight_smile:

According to your package… your screen dump looked like the below.

Some time ago, I shifted the “DanEDU” to be written in the end as “| DanEDU” and not in the beginning separated with a “.”. The below shown is how nodes look now. Besides, with the new look names are simplified (“FamilyDocument” has become “Family”)… I have walked through my nodes to make names shorter in general.

When we all are going to update to Dynamo 2.0 looks will change for all nodes there are coded as custom nodes (that are not Zerotouch). I change the look to anticipate this update. However, nodes will change even more when dynamo 2.0 is released because every “.” in a node name will end up as “folders” in the library view (the right pane in dynamo).
That is a very bad idea, but it seems like the dynamo team doesn’t care that this will have a huge impact on all custom nodes. So I am trying to prepare users of my package as good as possible to the day where dynamo 2.0 will be released, and still have a package there has the bare minimum for overview and usability. I am even considering moving towards zerotouch nodes because zerotouch nodes will not have this limitation.

image

1 Like

Hi @tvaughn, Would you mind to upload the package or share how to do create the Create share parameter custom node please?

Did you try installing the Orchid package? It looks like Dan EDU merged into Orchid.

As mentioned by @tvaughn the Orchid package has replaced the Dan EDU and I must say that it contains a lot more than Dan EDU and is much more robust!

@tvaughn i tried to download the Orchid package, but it referred me to github website and asked me to download and exe file. I am on company computer, I cant install external exe file. Is there a way to go around this ? please help, Thanks!

The way to install should be quite clearly explained on github you can simply copy paste the files yourself :slight_smile:

@Jonathan.Olesen sorry I am new with all this and a bit slow. You mean copy this? i tried to copy all this in codeblock or pythonscript node in Dynamo but it doesn’t work. Also tried to right clicked on that dyn file and save as. Dynamo just couldnt open the file.

You need to copy the content of the zip folder to the dynamo folder on your computer :slight_smile:

Do you know why it show in the manage package but doesn’t show in dynamo ?

Have you restarted? And which steps did you take?

I got it, i restarted Revit it did not show up, i reseted the whole pc now it works. Thank you very much Jonathan!