Closed sweep

How to sweep a closed polycurve with a closed profile?
Thank you

Seems to work :expressionless:

sweep.dyn (15.1 KB)

Thanks for your reply, but it won’t work Closed Sweep.dyn|attachment (17.3 KB)

@Vikram_Subbaiah I’m getting the same error as @jfbrigaud while using Revit 2019 and Dynamo 2.0.2

I use these versions.


The file I worked on was one of the daily builds 2.9.0.XXXX.
If Revit isn’t part of the workflow, you could consider using Dynamo Sandbox, maybe one of the latest daily builds

1 Like

Supposing it works just in the Sandbox environment, export to .sat and then bring it to Revit?
Are there more options?

1 Like

Try not jumping straight to a solid and instead build the surface:

The warning message is a bit cryptic, but the way I interpret it is that it can’t figure out where to ‘cap’ the shape after it’s done sweeping the surface because… well there isn’t a thing to cap is there - the surface closes itself.

A bit cryptic to be sure, but the error appears to be fixed in a future build as shown in the sandbox version.

1 Like

Thanks, it works by first going through the creation of a surface.

1 Like