Changing Sheet Number

Hello everyone!

I’m having problem with changing the Sheet Number. I have a bunch of text parameters for each sheets, what i want to link together with a “-” separation sign, convert them to text, and give this long text as a sheet name for each sheets. Does anyone knows what do I do wrong?

Flatten the output of the String.Join node.


Make sure you have a clean list.


I elliminated all the null values, but it hasn’t solved the problem?

What do you mean exactly? How i should do it?


So, no duplicate Sheetnumbers (like - - - - - - ) anymore? :slight_smile:


I deleted all the sheets, but one. It is working fine now, with only one sheet.
When i add a new sheet, it get’s corrupted. Whatever name’s i use in my custom text nodes.
My first sheet gets it’s name from the first sheet’s parameters, and it is only naming the first one, and doesn’t do anything with the second one.

Any idea, how to give the pairs one by one to the SetParameterByNode?

Sounds like a lacing or list depth issue.

Put a code block with the following afte the String.Join node:

Also you should confirm your number of sheets have a matching depth number of sheet names after that. They shouldn’t if you used a list.clean or list.remove null to remove the null values.

Also also you also have multiple sheets which are receiving the same name (indexes 11-13), which may or may not be by design here (I am unsure what the parameter names mean). You might want to add a number sequence to the end of the matching names become unique. This is not necessarily easier for Dynamo or Revit but usually is for us humans who have to ensure that everyone is looking at the same sheet when discussing something over the phone while someone is using a jackhammer in the backround.

Awesome! :slight_smile: This solved my problem! Thank you!

For the last advice. This naming method is identifying the sheets for everyone, involved in this project. There aren’t two of the same name. It is a huge project, so the method of numbering of the sheets came from way above of me. :slight_smile:

Glad that you have it sorted out! Please mark the correct post as a solution so that others can refer here if they have a similar issue.