Cannot change the value of instance parameters


#1

I’m trying to place family instances and modify the values of their instance parameters.

I get an error saying that the family could not be created (see attachment).

Before trying to change the parameter, just placing the instances worked fine.

What am I doing wrong?

Dynamo foil capture 1


#2

You are trying to set that parameter to a value that would break the family. You cannot perform this operation using Revit’s UI, so subsequently it will not work using Dynamo. Try testing the family to see what are the values that you can ACTUALLY set the parameter to before it breaks.


#3

Hi Konrad,

We thought this was the case, and did actually test the family. It didn’t break using Revit’s UI.

However, we suspected that something funky was happening in the family, and that it wasn’t an issue with Dynamo.

We made one of the three instance parameters into a type parameter, and tried again. This time it worked as intended.

I’m not entirely certain what the issue is, but what I am sure about at this point is that we must be very careful about how we model families, otherwise our Dynamo graphs will probably run into this issue again. Have you run into this issue in the past?