CAD lines to room separation lines has unexpected result?

I have a script that makes room separation lines from a CAD layers lines.

It works great the first time, but on any subsequent runs of the script, it moves the room separation lines from the first run to the applied level for the second run, and adds the new lines.

I have tried:
Closing and reopening both revit and dynamo between runs.
Unloading other CAD links.
Closing all other views.

I am at a loss why this would be behaving this way.

I did change the inputs in the drop down to match the new level/link.

Image of workspace:

So, to illustrate, I run it for the Level 9 cad file, on level 9. Works. Running again for level 8, adds the lines for that level 8 link, at level 8, but also the level 9 lines.

Any ideas?

1 Like

Hi @GJax89 ,

This is the way how Dynamo works, try searching the forum for “object baking”, “item baking” or just “baking” in general. :slight_smile:

1 Like

I will, thanks for the tip! Is it normal for it to do this even when its a fresh instance of dynamo and revit between runs?

1 Like

Yes that is how Dynamo is build up, when you do a new run the old results get automatically removed to keep your output tidy :slight_smile:

1 Like

I see. Thank you for the info! I don’t get to use dynamo much and hadn’t heard of this before.

1 Like

goe gedaan @Daan :slight_smile:

1 Like

Do you have any suggestions? I found some options based on another forum post directing me to here:

These don’t seem to work, I’m assuming because the objects are room separation lines and not extrusion based elements?

@GJax89 …you could try to run from player

. . . I have. . . that does not work, much like the other suggestions in the article.

As mentioned above I am thinking this is maybe due to them being lines and not solids?

Edit:


1 is the original lines, which are being moved up to level 2, after running again, in player, on level 2. Different level, different views, different links.

looks like a different layout on the next floor. :slight_smile:
different links you said?

Yes, So there is 1 cad file per floor, linked at the floors level. Lines marked 1 were placed on L1 after initial run of script.

Closing and reopening the script, closing or reopening dynamo or revit, or using player, and running again, result in lines in group 1 being moved to level 2 from level 1, and the lines for the level 2 link being created at level 2.
The links are intentionally not aligned for testing reasons.

Edit:
It makes it easier to tell if its still producing the above issue, for clarity.

i’ve made my share of embarrassing mistakes, that’s all i said
i’m sure with the help of the forum, it will be solved
i trust these guys

1 Like

Please help me understand, I am unclear which mistake ive made? If its something obvious I would like to fix it and test again

not sure… but do you stand on the right view when you run

Yes. I have the view I want them made in as the open active view. I even tried closing all other views, same result.

What’s the viewtype you open?

Floor Plan

You could do with one 3D view
That would exclude an error with that part

Running the script in a 3D View kicks an error as a result of the CW.RoomSeparator.FromCurve node produces null values.

Maybe an issue with sketchplane and active view?

could you expand your active view node ?