Broken Voronoi Cells


#1

Hi,

I’m trying to create a voronoi pattern, but the cells end up disconnected and incomplete. See screenshot below. Basically, i am trying to create a 2D voronoi pattern that gets denser as it approaches an attractor curve. Please let me know if you see what the issue is here. Thanks,


Creating voronoi patterns on a curved surface
#2

That’s an interesting problem. I can’t tell without digging deeper but are you generating the random points towards the attractor curve the way you want (with the appropriate level of densities for the design intent)? Can you upload the DYN and an example RVT file?


#3

Hi,

I cant upload files because it says I’m a new user. However, I have always had trouble with Dynamo’s Voronoi module. Every time I use it, no matter the density of UVs or simplicity of the algorithm, I always get disconnected / incomplete cells. Is this a common issue with Dynamo? Am I somehow using the module incorrectly?


#4

I think I remember something about Dynamo not displaying everything if the geometry was too large (but I might be mixing memories). Have you tried it with a lower density? It might be doing what it’s supposed to and just not showing you. (reaching a bit here)

until you have upload rights, you could use Dropbox or similar


#5

Hi! You can upload the file to google drive or somewhere else and share the link here.
You can also check if this is a visibility problem if you take the lines to Revit (but all the lines should be longer than 1mm) or you can trace the lines with points (Point at parameter) to see if points are placed on the empty spots.


#6

Hi,

You can download the dynamo file and corrosponding Revit family here:
https://drive.google.com/open?id=0B7dBxJ8qZf9oZmoyRFljSkhEazQ

You can adjust the density by reducing the amount of random points created. However, no matter the density, there are always incomplete voronoi cells.

Any suggestions would be appreciated. Thanks,


#7

I think it’s a matter of scale.


I noticed that the curve length is relatively small so I thought maybe the missing lines are too short to be calculated and I scaled the curve in revit x10.

While it looks better like this there are still some missing lines, and it looks even more as they are too short to compute or something:

P.S. Pretty interesting results messing up with this definition:


#8

Has anyone tried this in Dynamo 1.3 with the scaling options implemented?


#9

I also thought about this, but I still don’t have 1,3 on this computer.