Batch export from Revit to IFC

try to make the graph exactly as in post 3
you have more inputs missing

Hi,

You have to connect the view elements in the input views and not strings.

Thanks for your responses. I’ve tried connecting the view elements and get the same result. I’ve also recreated post 3 and am also getting “null”. Have attached screenshots of both

Hi,

It’s probably a list level issue.
Add a List.Flatten node before the inputs views and filenames :
flatten

Example :

Great - this seems to have sorted it! Thanks so much!

I have just released an update which includes IFC export…

Thanks. Great help! But I am not able to find the following node. Can you please help ?
image

Hi,

This node exists in many packages.
In Rhythm, Genius Loci and other.

1 Like

Thanks

Bonjour Alban, Could you please suggest something on this?

i think this workflow is for project files, not families.

Do you have any suggestion for families? Thank you

I have a large range of nodes for both Families and IFC export…

https://forums.autodesk.com/t5/revit-mep-forum/export-revit-family-to-ifc/td-p/6311592

I need to convert 100s of family files to IFC which is tedious doing manually. I don’t see any automated solution on that link too. Thanks anyway @Marcel_Rijsmus

so you need a clean revit project file, place the family in there, export to IFC, delete the family and place the next and repeat this proces
i cannot test this (no Revit)

1 Like

you have sent me a personal message, but that wont get you any help from the community, so please repost that message here.
thnx

It doesn’t seem possible to export IFC from families.
The export option is grayed out in the family interface.
The error with the Export IFC node is “Exception: This Document is not a project document.”

In this case, the desired family file is loaded into the project file and the document .rvt project file is used here but problem remains unchanged!.

you are feeding the filename input with the string {3D}
i dont think you can create a file with a name like that