Background Viewport bug

I just reinstalled Windows 10 with all drivers correctly installed.
When I launched DynamoSandbox.exe from the DynamoCoreRuntime2.2.0 (published on DynamoBuilds.com), I got a strange bug where the viewport was not available at all, and just show a 2D grid. The left panel is also empty (though all the nodes are still available in search and still functional)

FYI, I have Revit 2020 installed and chose NVIDIA GPU when launching the Dynamo Sandbox.

@JacobSmall

Is it a laptop?
Mine also does not show the 3D view and the 2D underlay only.
Maybe HelixToolkit is not compatible with something?

@LongNguyen Have you tried adding DynamoSandbox.exe inside Nvidia control panel?
images

Yes laptop indeed.

Still worked fine on the other laptop of mine.

Yes I did that as the very first thing.

@LongNguyen

The library looks like it may be a CEF issue, which doesn’t make much sense but it could be a think. Do you have any warnings in your console or logs?

The workspace looks like backround 3d preview is turned off - which is one of those settings I don’t remember unless I’m having a problem like this (and it’s been awhile). Can you confirm that’s on? I’ll let the dev team know what you’re seeing and will see if they have any other thoughts.

I think in my case the menu item to enable the background 3D preview was not even there, as if it was disabled because the hardware does not support it ( I have Radeon 7) or the library was not found.

It happened some time ago but I can check at home later in case no one figured out a solution until then.

@LongNguyen can you check if ALL the dll files in the Sandbox folder and subfolders are “unblocked”? Windows loves to block everything that comes out of a downloaded zip file.

1 Like

The library actually did load fine the very first time I launch DynamoSandbox.exe (When there is no Dynamo folder existing in the %AppData% folder, after that it wont load in subsequent lauches unless I delete the Dynamo folder in %AppData%)

I thought of the dll file being blocked too. So I tried to extract the Zip on another laptop and verified that DynamoSandbox.exe launched and behaved correctly. Then I copied everything over to my main laptop using a USB drive and the problem still persist. So looks like it is not because of Windows blocking the dlls as it only does this to files downloaded directly from the internet.

Everything was working fine last week on the same laptop, the problem only appeared after I reinstalled a fresh version Windows 10

Yes also for me, the background 3D preview was not available in the menu either.

Hi @LongNguyen
please try the following:

  • follow this Wiki: https://github.com/DynamoDS/Dynamo/wiki/How-to-Utilize-Dynamo-Builds
  • removing all packages from the 2.2 appData folder for Dynamo Core
  • make sure you add this specific dynamoSandbox.exe to nvidia control panel - I know you already did - but make sure it’s not some other sandbox in some other location.
  • what GPU?
  • does Dynamo work in Revit here?
  • post your console log.

make sure you install the dependencies listed in that wiki.
visual c++ redistrib (2015 or 2017) and directX if it’s a new windows install.

Thanks Micheal. Problem solved!

DirectX was missing. I was not aware that Dynamo/HelixToolkit requires the old DirectX and thought that the DirectX that comes with Windows 10 would suffice.

1 Like