"Area Scheme with that name not found"

CreateAreaboundariestogether.dyn (41.3 KB)
I am trying to create Area boundaries (solved) togethere with area plan.
Unfortunately I get the error from the title.
I probably mistakenly assuming that Area Scheme means “Gross building Area” for instance. i tried to use the Color scheme name but same result.

If you go to the “Area and Volume Computations” settings you’ll see all of the defined area schemes in the project:

“Gross Building” is a built in one. In your case, try removing the " Area" part from the scheme name input

thanks, for the moment.

I am getting a “Deferencing a no pointer” error while trying to make a total of gross area.
Can you help me figure out how to over ride that. Thank you.

You are trying to get the Area from the Name of the Area Scheme of the Area. That is not going to work.

You need to use a List.FilterByBoolMask instead of your filter Node and take a better look at what you are passing. You will need the Area element itself to query it for it’s area.

Hey @Bjorn_Keulemans1 Thank you, that helped. But I still have some issues.
Here is how I am thinking, I was able retrieve areas If I take input of Area. you can see that in bubble 1.
The red arrow shows the node flow “Area >Area scheme>Gross/rentable.
The blue arrow is how we should reverse the flow " Gross >Area Schreme> Area”
I believe there should be a node at second bubbles to retrieve the “Area scheme” into 'Areas".
Area can be directly used after that to sum and etc.
I have tried with “Element name” & “Element Category” as you can see in picture, but that did not work.
Thank you.