Analysis.CalculateWithSave ERROR

Hi Everyone,

I am trying to run the analysis of a truss structure using Robot. However, I keep getting this error (image below) with the Analysis.CalculateWithSave.

Thank you in advance.

Hi @benameram

could you provide us some more information?
as like which way are you running your script?
1- Revit<>dynamo<>Robot
2- Dynamo studio<>Robot
3- Dynamo Sandbox<>Robot

and can you show the values from the list create?

Gr Edward

Hi @1234eddie

Thank you for your reply. I am using dynamo from Revit and exporting it to Robot.

I tried to close it all down and re-open and re-run and it has now worked. which is something that I found quite frequent in dynamo. Sometimes I get unrelated errors and warnings.

However, I have come across another problem now, which proves my point that dynamo sometimes creates errors. Everything is working fine in this script and the previous node as shown below has a list of 32 values. However, the next node has Null values. Although, I am quite unsure if this problem is related to the python script node (the list value is zero).

Hi @benameram

i’m working mostly with Dynamo studio<>Robot. and what i figured out if you use a python node between parts of the structural analysis packages, it won’t work due to the speed of the python script.

Back to your problem you have right now, i’m think it’s one of the autodesk university examples? which one?
can you provide the dynamo script or the python code, so we can see what’s should be going on inside.

i know @gwizdzm is related to the structural analysis package(or @JacobSmall knows probably who else)

Yes, its from the “Optimized Design and Fabrication Workflows with Dynamo” lecture. The python script provided is as below.

I would have to see what is happening in the Python node and a preview of that data to know what is up. My guess is that the output isn’t really a list based on the error message.

I also would recommend moving to Dynamo Sandbox instead of Dynamo Studio unless you need the import/export dwg nodes. Studio is capped at 1.3.4 which is like 3 years old at this point, and as such you’re missing out on 3 years worth of improvements. Dynamo for Civil 3D or the LinkDWG package might also be a better solution if you need the dwg interaction.

Hi @JacobSmall

Thanks for taking the time to reply.

I have downloaded dynamo Sandbox but I am getting different errors as shown below. I understand that this has occurred before with other users. But I have the latest Revit and latest Dynamo Sandbox versions.

I have tried to attach the script but it won’t let me. if you want to view my script pls let me know and I can send it.

Thank you for your help.

In your case running out of Dynamo for Revit was fine - the specific issue is likely tied to the python code, can you post that with formatting and I can have a look? Unfortunately I don’t know or have robot at this time.

I am using the Python script Node but I haven’t actually typed up the code. I thought this node already has the code embedded in it. Please find image below the code I got from Autodesk University.

Ah, missed that before. Sorry.

Can you preview the resulting data from the python node?

the input into the node is roughly 31 lists but the output is 0. That’s the problem.

A single zero, or a list showing just a zero? At a minimum there should be three outputs… can you link me to the graph or post it here so I can find that bit of python without having to retype it?

ye a single zero. yes you’re right there should be three outputs. I have attached the dynamo script. I am only using the “Python Script” Node, so I didn’t actually type the code. I thought that the code is already embedded into the Node.

truss3.dyn (217.4 KB)

1 Like

Thanks - will look into shortly. :slight_smile:

1 Like