All Nodes on top of each other

It happened to me when I had 2 version of Dynamo installed one older 1x and 2x version but by default opens the older version of Dynamo and nodes are on top of each other

Thanks @Michael_Kirschner2, I’m trying to recreate the problem but having poor luck. I reinstalled GD and didn’t have any issues with it. If I run into the issue again I’ll post the listDLL.

As @RubenVivancos pointed out, I noticed a version of Dynamo 0.9 was still installed on my computer, so I uninstalled that (however, this was still installed at the point of time I had resolved the node-stacking issue).

Edit: Same issue reoccurred. I’ve attached a screen capture this time. I haven’t touched Dynamo since the last time I posted, when it seemed to be working fine.

@Michael_Kirschner2 I tried to figure out the DLL software, but I know little about computer programming and I’m not entirely sure how to use the ListDLLs utility. When I open the downloaded application, a window opens with a list of all DLLs and auto-scrolls to the bottom, and then exits out without prompt.

I deleted Generative Design (once again) that I had previous reinstalled (which was working - please see my last post), and the nodes are now fixed in my Dynamo. Hope this update helps figure out the root of the issue.

Can you post your Dynamo log file from before uninstalling generative design, and the associated Revit journal?

@JacobSmall Tried to attach the journals, but I’m getting a warning saying that new uses cannot attach files.

Bumped you to the next level of permission. If they don’t post now can you provide a link to a web hosting service like Google Drive, Dropbox, OneDrive, Box, WeTransfer or similar?

Sure thing!

dynamoLog_eb127b59-2c3e-4925-90aa-7d1f1f078c53.txt (58.7 KB)

Revit Journal:
https://we.tl/t-T80GIlE1ST

Hi @ariderAEE99 - to use listdlls run it from a command prompt window

you’d run something like path\to\listdlls.exe -v Revit > path\to\someoutput\textfile.text

this will run listdlls on Revit (it needs to be running with Dynamo open and the problem reproducing) and then save the output to a text file (you could also copy paste it here) - then upload the text file here for us to see or DM it to me or Jacob.

Hello, I was working inside of Dynamo one night and this problem plagued me as well. Everything was in an orderly fashion and then I came back to open up a file with stacked nodes. I was wondering if anyone has come to the root of the problem and identified how it can be fixed. Thank you for your time!

To date, every time it has come up it has been due to a conflicting add-in or lack up update.

  1. Update Revit to the latest version that you are using.
  2. Launch Revit, open a model, launch Dynamo, open a graph, and see if the issue persists. If so, proceed to step 3. If not you’re good to go, but try to keep updates installed going forward.
  3. Close Revit, and then disable all Revit add-ins.
  4. Launch Revit, open or start a model, launch Dynamo, open a graph, see if the issue persists. If so close Revit, and provide your Revit Journal and Dynamo log in this thread. If not, proceed to step 5.
  5. Close Revit and re-initiate your Autodesk provided add-ins. Repeat step 4 and confirm the issue doesn’t persist. If the issue pops up, be sure to update the add-in. If the issue doesn’t pop up, proceed to step 6.
  6. Close Revit and re-initiate a few add-ins and re-test. Do maybe 3 or 4 at a time until the issue reproduces, keeping any offending add-in out until you have tested all passing add-ins.
  7. Update the offending add-in, or keep it off the system until a version is issued which resolved the problem.